Mail Not Working


#1

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server =mail.asianpublication.com
smtp_port = 587

; Enable SMTP authentication
smtp_auth = tls
smtp_username = editor@asianpublication.com
smtp_password = mypassword

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
allow_envelope_sender = On


#2

Hi @rvcrajkumar,

Which of our applications are you using, and what version? (Please include this information in your posts.)

Regards,
Alec Smecher
Public Knowledge Project Team


#3

am using 3.0.2.0
OS platform Linux
PHP version 5.4.45
Apache version Apache
Database driver mysql
Database server version 5.6.31-77.0-log


#4

Hi @rvcrajkumar,

Can you describe what happens when the system attempts to send an email? Do you see an error message, or is the email message simply never received?

Regards,
Alec Smecher
Public Knowledge Project Team


#5

when i activate smtp i did not receive emails i don’t get any errors but if if turned off smtp i can receive email but it goes to spam folder


#6

Hi @rvcrajkumar,

I suspect in both cases your messages are getting spam-trapped. It sounds like OJS is correctly configured, but you may have to do some additional server configuration (e.g. DMARC rules). I’m afraid that’s outside the scope of this forum.

Regards,
Alec Smecher
Public Knowledge Project Team


#7

While activating smtp mail is not working
if i turned off everything goes fine but i need smtp for gmail account pls help me out
smtp = On

; SMTP server settings
smtp_server = smtp.gmail.com
smtp_port = 25

; Enable SMTP authentication
; Supported mechanisms: ssl, tls
smtp_auth = tls
smtp_username = editorasianpublication@gmail.com
smtp_password = mypassword

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
allow_envelope_sender = On

; Default envelope sender to use if none is specified elsewhere
default_envelope_sender = editorasianpublication@gmail.com

; Force the default envelope sender (if present)
; This is useful if setting up a site-wide noreply address
; The reply-to field will be set with the reply-to or from address.
force_default_envelope_sender = On

; Amount of time required between attempts to send non-editorial emails
; in seconds. This can be used to help prevent email relaying via OJS.
time_between_emails = 3600

; Maximum number of recipients that can be included in a single email
; (either as To:, Cc:, or Bcc: addresses) for a non-priveleged user
max_recipients = 10

; If enabled, email addresses must be validated before login is possible.
require_validation = Off

; Maximum number of days before an unvalidated account expires and is deleted
validation_timeout = 14


#8

I’m pretty sure gmail does not host secure SMTP on port 25. See:


and
https://pkp.sfu.ca/wiki/index.php?title=Using_gmail_SMTP