Mail address in contact details disappears

I Noticed that in OJS when I add new user and enter mail address in blingual interface. So when I clicke below in order that double editor disappear entered details for mailing address disappear so I have to enter them again. I experienced several times O i think that there is some kind fo glitch that cause that. Please check that.

Hi @vvucic

Could you please tell again in which order you try to do what? – I cannot reproduce it… :-\

Thanks a lot!

When I add that mailing address is: Peter Peterson, Faculty of Some Science, Some Street, 28, Town, State and I click below that field or on the right side that address disappear after clicking on Save button.
When I click on Save button without clicking below the field it is saved.
In bilingual interface fields somehow overlap and I click below or aside just to let those overlapping fields disappear but that cause mailing address to disappear after clicking on Save.

Please check. I have had that case several times so it should be reproducible.

Hi @vvucic,

Hmmm… Strange… I cannot reproduce it… :-\ I’ll check if others experience the same…


I encounter something similar: if I enter the mailing address, click Save, navigate to other tabs and come back, the first letter of the mailing address changes to <

OJS, upgraded from 2.x

no such issue with clean install of OJS 3.1

Phew… This gets even stranger… :smiley: :wink:

@czirfusz, could you post here what you type in? – I cannot reproduce it…



  • I typed in what is on the screenshot above.
  • Then I clicked on Save.
  • Changes were saved, I saw the proper text.
  • If I then navigated to, say, Sections (or any other part of the OJS page) and came back to Contact, I saw for less then a second the proper text, then the first character changed to “<” (see the screenshot below). I tested with any kind of text, single-line, multi-line, text starting with letters and numbers; same strange behaviour.

Oh, and what came into my mind as perhaps related:
We migrated from OJS 2.3.6. Back in that system, in the same field, “Mailing address” I had the recurring issue that under Journal Setup Step 1., part 1.1 General Information if I typed anything into the Mailing address field and saved, the text “Array” appeared, and not the text I typed.

Solved: with entering html code it works fine.

Hmmm… so what did you entered that worked?

I entered this, and works fine:
<p>Tóth Kálmán u. 4.<br />1097 Budapest</p>