Login in OJS after upgrade

Hi @asmecher,
I’m tried to upgrade the OJS from version to and we have always the same problem, after upgrade sucefully (from github and the last time is download the zip file) I can’t authenticate with any user in the site. the php version is PHP 7.4.21 and mysql57-community-release-el7-11.noarch. I put the variables in the php.ini
error_reporting = E_ALL , display_errors = On ,display_startup_errors = On, log_errors = On. in the config.inc.php I put the variables show_stacktrace = On, display_errors = On,log_web_service_info = On, but not show me a error for that and restart httpd and not show me a rror.

when I checked the date_last_loggin in the table users show me the date according a authentication attempt. the same when I looked the table sessions show the registers… but I can’t authenticate.


The web isn’t show me a error, but when I tried to register a new user show this messages.


I tried to update a password with the same method in config.inc.php than the database had before a the upgrade, it’s MD5, with the sentece UPDATE users SET password=MD5(‘testuser’) WHERE username=‘testuser’;
but the problem is continued, I can’t authenticate with the admin and any user.


Really I don’t know how can I check the authenticate and why the admin menu isn’t show.
Can you help me?

Hi @JCar

have you checked whether you keep the same encryption method (SHA1 or MD5) from your previous OJS version ?


Hi @israel.cefrin, thanks for the suggestion. the answer is NOT, we doesn’t modify this option Before and after upgrade. if the problem is the authentified, I don’t understand when I tried to login, the site register the new sesions rows in the sessions table and change the date_last_loggin in the users table .

we had and have the same option MD5.
maybe the problem is for this that:

in the production site has a https certified. but in the test server doesn’t have a security certified. when I tried to login after put the same admin user, show me than the Cookie OJSSID is refused in the test server. and we have a alert with util.js, show me a alert for the this files…

Now I am thinking than maybe the problem is the version of PHP. Maybe y I want to tried to instal php-74 from other origin. and check agaian the installation with version…Really I don’t know what I can do it for checking the sesion process and why doesn’t works.

Any suggestion for help me ?

Thanks in advanced ,

Hi @JCar

What is the PHP version you have in your webserver currently ?


Hi @israel.cefrin,
in the test server where I have a site in ojs the version of php is:

PHP 7.4.21 (cli) (built: Jun 29 2021 15:17:15) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies


Server version: Apache/2.4.6 ()

Thanks in advanced,

One more question, you mentioned that in your testing server you don’t have SSL certification.
Have you adjusted your base_url parameter removing the https call ? It might be causing the cross HTTP request unsecure.


Yeah I change https for http in the parameters base_url and base_url[index], base_url[any_Journals]

I’m having the same issue after upgrading OJS from 2.3 to 3.3.
I can’t even register a new user.
Is there a way to debug the form submission?