Links in google shcooler 🙏

Description of issue or problem I’m having:

Articles do not appear in “google scholar”.

Steps I took leading up to the issue:

upgrade ojs 3.3.0.8 to 3.3.0.9

What I tried to resolve the issue:

upgrade ojs 3.3.0.9 to 3.3.0.10

Application Version - e.g., OJS 3.1.2:
ojs 3 3 0 10
php 7.3

Additional information, such as screenshots and error log messages if applicable:

After updating “OJS”,
I wanted to update the “plugins” but this error appears : “The tar command is not available. Please correctly configure it in your “config.inc.php”.”

Help me it’s urgent :pray: :pray: :pray:

Hi @rebas_saber
Depending on your operating system, in your config.inc.php file you must indicate the path of the tar command, normally it is specified like this:
tar = /bin/tar
You need to ask your administrator for the exact location of this command and make the necessary changes.

Hi @dagosalas , thanks for reply.

The pressing problem is that links are not showing up in Google Scholar
Please help me solve this problem :point_down: @dagosalas

This is a secondary problem

I need a little more information:
Have the articles never appeared or suddenly disappeared?
is the google scholar plugin active?
what is your journal url?

@dagosalas

the articles suddenly disappeared
oogle scholar plugin active? = YES
mbmj . org

@dagosalas

more information, i have this error in below from file “error_log”

[16-Mar-2022 19:37:31 UTC] PHP Fatal error: Uncaught PDOException: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation ‘=’ in /x /x /x /lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:78

I don’t know if it’s related to the error, but if there is a problem, all the tables must be utf8_general_ci, you need to change them.

@dagosalas

My database its “utf8_general_ci” and type : “MyISAM”
All my tables its “utf8_general_ci” and type : “InnoDB”

Hi !

Upgrading from one version to another doesn’t delete the articles in google scholar, maybe it’s a different problem.
Please read and follow the instructions in this manual Google Scholar indexing guide
Read Google Scholar Indexing
Also read the google scholar document: Google Scholar Help

If you follow the Google Scholar guidelines, it is very likely that Google will include your journals.

Hi @dagosalas

Note: Before the update, it did not appear in “google scholar”, I do not know when it disappeared.
I thought an update would solve the problem, but it still didn’t show up in “google scholar”.
These errors appear frequently in “error_log”.

[17-Mar-2022 10:06:16 UTC] PHP Warning:  ini_set(): A session is active. You cannot change the session module's ini settings at this time in /public_html/lib/pkp/classes/session/SessionManager.inc.php on line 69
[17-Mar-2022 13:15:20 UTC] PHP Fatal error:  Uncaught PDOException: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '=' in /public_html/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:78
[17-Mar-2022 08:52:35 UTC] PHP Warning:  file_exists(): open_basedir restriction in effect. File(/bin/tar) is not within the allowed path(s): (/home:/home2:/home3:/usr/local/lib/php:/tmp:/usr/lib/php/:/usr/share/l.v.e-manager/:/opt/alt/php73/:/usr/local/lsws/) in /x/x/public_html/lib/pkp/classes/plugins/PluginHelper.inc.php on line 54
[17-Mar-2022 17:55:16 UTC] SMTP Error: data not accepted.SMTP server error: DATA END command failed Detail: This message was classified as SPAM and may not be delivered
[17-Mar-2022 18:41:48 UTC] PHP Deprecated:  Non-static method Core::_getBaseUrlAndPath() should not be called statically in /public_html/lib/pkp/classes/core/Core.inc.php on line 231

If the plugin is active you have to wait, however it is not a guarantee, there may be external factors. Actually the best way is to follow Google’s instructions to be included in Scholar.