"Journal Redirect" missing?

  • Application Version - e.g., OJS

  • Description of issue

I am trying various solutions to rewrite my index.php/journalname to simply the base URL, as this is a single journal instance. .htaccess solutions have not been working. I ran across posts saying to use the Journal Redirect feature in Administration->Site Management->Site Settings, but I do not see this option.

Is this no longer a feature?Capture

Hi @guitman444,

If you go to Administration → Site Management → Settings - it should appear, provided you are in the admin role? Here’s what it looks like for me in an OJS

Screen Shot 2021-03-02 at 6.37.32 AM

PKP Team

Hi @rcgillis

I don’t see it either in OJS 3.2.1-4 with admin user (url is “admin/settings”).
It is also missed in all the journals I tested (over 3.1.1-4, 3.2.0-1, 3.2.1-1, 3.2.1-2 and 3.2.1-4) and log is not yelling any error.

On Administration > Site Managment > Settings, only “Languages” tab is available:


Could be related with wrong permissions migration for “admin” user?
It’s wired because it is also missing in my laptop’s clean installation.



I just made a clean 3.2.1-4 installation (English only) and the missing tabs are still lost.

Here you have a detailed list description of the installation:


@rcgillis what url are you visiting to get all those tabs?


Ok… Looks like “is not a bug, it’s a feature”:

Tested: when I created a second journal, the missing tabs suddenly appears.

So @guitman444 if you want to see the full UI, you need to create a secondary journal.
If you don’t OJS works with journal redirection by default… but if you need to be aware that it won’t fix your url.


1 Like