Issues edit problem

I am trying to edit the added issues, but it shows an error: “Failed Ajax request or invalid JSON returned”

How to fix this error?

Hi @zviadi_beradze,

Which version of OJS are you using (e.g. 3.3.0-13)? In the future, please include this in your posts as it assists with others’ troubleshooting. Also: have you checked your PHP error logs? That usually provides more clues as to what might be occurring.

Best regards,

PKP Team

version: ojs-3.3.0-15
php error:

[18-Aug-2023 11:29:36 UTC] PHP Warning: filemtime(): stat failed for lib/pkp/templates/controllers/grid/issues/issue.tpl in /home/bsuedu/public_html/subdomains/ojs/lib/pkp/classes/template/ on line 51
[18-Aug-2023 11:29:36 UTC] PHP Fatal error: Uncaught → Smarty: Unable to load template ‘app:controllers/grid/issues/issue.tpl’ ←
thrown in /home/bsuedu/public_html/subdomains/ojs/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_template.php on line 196

Can you give us instructions on how to proceed?

Hi @zviadi_beradze,

The file lib/pkp/templates/controllers/grid/issues/issue.tpl is missing from your installation. Make sure all the files in the installation package are present on your server.

Alec Smecher
Public Knowledge Project Team

There is no lib/pkp/templates/controllers/grid/issues/issue.tpl file in the downloaded ( archived file (ojs-3.3.0-15.tar.gz)

I saw the files on

I uploaded it to my server but it didn’t give me results, it’s probably an old version because it was uploaded 2 years ago

What should I do?

Hi @zviadi_beradze,

My mistake – that should be templates/controllers/grid/issues/issue.tpl, not lib/pkp/templates/controllers/grid/issues/issue.tpl.

The best place to get a file (if you’re missing one) is from the OJS downloads page (see the Release Archive link), making sure to match the download version with the version you’re running. (You could also get it from Github, making sure to choose the label that corresponds to your version, but you might have to chase it down in a few repositories.)

Alec Smecher
Public Knowledge Project Team

The problem is solved

The file: issueToc.tpl was missing in the templates/controllers/grid/issues/ folder, I uploaded it and the problem was solved

Thanks for the help!

This topic was automatically closed after 5 days. New replies are no longer allowed.