Invalid issue requested error (OJS

Hi Everyone!

Sorry if my question is a little bit stupid, but I’m just a librarian, not an IT person.

So since we updated to the version, we have this proble:
one of my editors made a new issue, upload the items belongs to the issue, but when she finished, and check the issue, she saw it shows 8 items, but when she hit the edit button saw no items, just the empty field.
We checked the submissions, they are there, and they are connected to the issue, but when you publish the issue, it’s nothing there. I tried to unpublish, and publish again, then I got this invalid issue requested error.
After this I reproduce this error with a nother journal of ours. When I uploaded a new publication, I cannot se it under the issue.

Could someone help me what is the problem here?


Hi @lovaszdavid,

Not to worry, all kinds of questions and levels of experience are totally welcome.

Have a look over this post, which I think will answer your question. Essentially it’s a workflow change starting with OJS 3.2.0 that’s tripping you up. OJS 3.2.0 Table of contents on numbers - #14 by NateWr

Alec Smecher
Public Knowledge Project Team

Hi Alec!

The video was very useful, thanks. I will share it with our editors.

But it didn’t solve my problem comletely.
So, after I watched it, I try to schedule.
As you see, at the beginning it seemed to be ok
but after I hit Schedule, the same error appeared.

What do you think, where can we look for answers?