Install OJS 3.0.2 on Windows with PHP 7.1.8


I am trying to install version OJS 3.0.2 on a Windows server running IIS PHP 7.1.8 and MariaDb.

I get the initial install page and I fill out all the fields and click install

It then redirects me to http://localhost/index.php/index/install/install which is blank.

I am not seeing any errors in my PHP error log file.

Any suggestions?


Did you use “mysqli” instead of “mysql” in the database setting in



The database section of the looks like this

driver = mysql
host = localhost
username = OJSDBManager
password = 
name = ojs

; Enable persistent connections
persistent = Off

; Enable database debug output (very verbose!)
debug = Off

with the password removed.


Then try with
driver = mysqli

instead of
driver = mysql

I hope it will work.



That worked!

Thanks so much,

1 Like

I have entered mysqli and it moved forwarded but I am prompted with error message:

A database error has occurred: Specified key was too long; max key length is 767 bytes

please advise

Hi all,

This is a MySQL/MariaDB error message. See mysql - #1071 - Specified key was too long; max key length is 767 bytes - Stack Overflow for details. The suggested resolution seems to be upgrading your MySQL/MariaDB installation.

Alec Smecher
Public Knowledge Project Team

I just had the same problem on a fresh debian 9 installation. The upgrade from to 3.1.2 ended in:

ERROR: Upgrade failed: DB: Specified key was too long; max key length is 767 bytes

I’m running:

~ ᐅ php --version
PHP 7.0.33-0+deb9u3 (cli) (built: Mar 8 2019 10:01:24) ( NTS )
~ ᐅ mariadb --version
mariadb Ver 15.1 Distrib 10.1.37-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

Those versions are the current versions provided by apt.

@asmecher: Do you know what version will be sufficient?

It think it would be nice to update the system requirements on the downloads page as long this is an issue happening with the default versions provided by apt.

I fixed some issues in OJS installations bz upgrading PHP to 7.2 instead of keeping on version 7.0.x

I finally was able to successfully upgrade, avoiding the error. The solution for me was to use real mySQL. So I removed mariaDB, installed mySQL and then the update worked.