Help for enable TinyMCE on ojs 2.4.8

Módulo TinyMCE

Este módulo habilita la edición WYSIWYG (“lo que ve es lo que obtiene”) de áreas de texto del OJS mediante el uso del editor de contenido Habilitar ACTUALIZAR MÓDULO ELIMINAR MÓDULO

when press enable (habilitar) this redirec to

Hola que tal / Hello @EriXon_ramirez

Su pregunta parece más a cerca de la categoria questions do que una “feature request”, así yo cambié las categorías.
¿Al hacer clic en “habilitar” sólo redirecciona o redirige y habilita el módulo?
¿Podría leer su log de servidor web para verificar los mensajes sobre esa acción y lo que dice su servidor cuando hace clic en el botón habilitar?


Your query looks like closer to question than a feature request so I moved to this category.
When you click “habilitar”(enable) button it only redirects or redirects and enable?
Could you check your webserver log to verify messages about that action and what your server says when you click enable button?

Israel Cefrin
Public Knowledge Project Team

Solo redirecciona y apunta a una url.

Hi @EriXon_ramirez

The Spanisch translation file had a strange ‘"’ for the link. Here is the patch: pkp/pkp-lib#2852 fix spanish locale for TinyMCE plugin by bozana · Pull Request #1569 · pkp/ojs · GitHub (also in GitHub Issue fix spanish loclae for tinyMCE plugin · Issue #2852 · pkp/pkp-lib · GitHub). If you apply those changes, the problem should be solved.



It Works!, Trabaja!
Thanks a lot, Muchas Gracias!!

1 Like


we had the same problem, and after applying the patch, we can enable or disable the TiniMCE Editor, but when we enter something into WYSIWYG Editor and we save it, it doesn’t work, it doesn’t save anything, unless when we open the HTML Editor, then it save whatever we enter in the textarea.

It occurs with every textarea field, in submission metadata editting and in configuration editing (2.5 for example).

Thank you from now,

best regards
Jose Angel Navalón,
University of Valencia.

Hi @jnavalon

Hmmm… Strange… Do you get/see any PHP errors in your apache error log file or any JavaScript errors in the browser web console/development tools?
Hmmm… :-\


The problem was that when I tried to edit some textarea field of the setup pages, with more than one textarea, it only saved the content in the last one.

But other plugins worked fine, like CustomBlock and StaticPages, so, I finally modified to have working the plugin.

Thank you.

Kind regards,
Jose Angel Navalón