Footer doesn't appear on the homepage


I have set page footer in Setup->The Look. However it appears on every page except the homepage. Should I do any change in the template files for it to be appear?

Our journal haven’t published any issue yet.


Hi @salehig,

which version of OJS are you running, and did you do any modifications to the code? The footer should display on every page, including the start page of the installation.

Can you provide a link to your journal?

In addition to @mtub’s questions, keep an eye on the URL. There are actually a couple of different contexts within OJS: the Site level and the Journal level. If the URL contains “index” where you would otherwise see your journal’s Path setting, you are actually in the Site context and the custom footer from the Journal context will not apply.

For example:

If you are only using one Journal per Site, you may be seeing the Site homepage when you expect to see the Journal homepage. In this case, consider using the “Journal redirect” option in User Home → Site Administrator → Site Settings.

Thanks for your replies.

Here is the address of our journal: v (a bit behind)
We have two journals under one site.

I noticed “Additional Content” section in Setup->The Look has the same problem. I set some text in the setting but it doesn’t appear on the homepage.

Our other journal (on the same code base) is quite fine and has the blocks of:
div id=homepageAdditionalContent
div id=creativeCommons
div id=footer

Our student success journal doesn’t have any of these blocks.

I also don’t know how to display Creative Commons logo aromatically. At the moment I have added the logo image and text in the footer. Our other journal has it without being set in the footer.

I’d appreciate your help in that.


I’d suggest you try removing the additional content you’ve put in “homepageJournalDescription”, see if the footer appears, and then work it from there by adding your content again. I’ve noticed that you’ve changed the twitter button code and that you’ve put the twitter javascript into a CDATA element. Right now your page breaks at that point, your homepageJournalDescription div isn’t closed and everything that would load after that div is not loaded. The footer would be included at the end of your content div, but that div is not closed (as is your whole html page).

Could you try removing the code or maybe just the twitter button code?

Thanks @mtub.

I removed those additional content from homepageJournalDescription. The footer still didn’t appear. I use chrome. Developer panel doesn’t show any un-closed div.


I found what the problem was. We have a block plugin which lists the summary of the issues on the home page. Unfortunately this plugin didn’t use to handle cases with no issues. As we haven’t yet published an issue in our new journal this caused problems on the homepage. I fixed the plugin to do that and footer is back on the homepage.

Thanks anyway.

1 Like