Font Sizer not working in 2.4.8-5


  • OJS 2.4.8-5

I have just realized that the font sizer is not working on most visible pages of my journal. I have not checked everything, but it only displays on the Site Admin pages (especially infuriating: where you can clear the template cache). I also cannot attest to when this started happening, I usually disregard this function completely - I did attempt to upgrade to PHP7 recently but I cannot imagine this had any effect.

I have found that the javascript was missing from the template page through this ticket, which describes a similar issue to mine though in OCS.

I’ve added the javascript listed in the bottom post to my header.tpl, which worked the first time I reloaded the site, then never again. I have also tried adding the same code to \templates\common\header.tpl, which causes the font sizer to appear and disappear very… flippantly. Sometimes every other reload, sometimes it takes 3 or 4 tries. It seems to work more often in Chrome than Firefox, but it may be observer bias.

I’m not receiving any error messages.

Thanks in advance!

1 Like