Fehler bei Upgrade auf 3.0.2


#1

Gruß zuvor!
Beim Upgrade von OJS 2.4.x auf 3.0.2. sind bei uns Fehler aufgetreten. Nach dem Hochladen der Dateien und Ersetzen von public und config kommt die Fehlermeldung:

open_basedir restriction in effect. File(/lib/pkp/js/lib/jquery/plugins/validate/localization/messages_de_DE.js) is not within the allowed path(s): (/var/www/clients/client45/web141/web:/var/www/clients/client45/web141/private:/var/www/clients/client45/web141/tmp:/var/www/fzwp.de/web:/srv/www/fzwp.de/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client45/web141/web/lib/pkp/classes/template/PKPTemplateManager.inc.php on line 571

Bei cache und public habe ich die Rechte 775 eingestellt.
Wenn ich trotzdem mit dem Upgrade fortfahre, kommt die Fehlermeldung:

Ein Datenbankfehler ist aufgetreten: Incorrect table definition; there can be only one auto column and it must be defined as a key

Ich habe OJS bei einem Provider installiert, haber also nur FTP-Zugang zum Server. Kann mir jemand helfen? Danke, Daniel von Wachter


#2

Problem verschwunden, nachdem ich ein früheres Backup der Datenbank eingespielt hatte! Ich hatte die Datenbank wohl durch falsches manuelles Löschen von Fake-Usern beschädigt. Hatte dazu die Tabelle “users” als ods exportiert, dann die Fake-User gelöscht, dann wieder importiert. Das ist anscheinend nicht die richtige Methode.