Falla en Actualizacion hacia 3.2.x.x - Error en la pagina principal

Buenas a todos, tengo 2 problemas puntuales mas que nada son detalles estéticos, luego que realice la actualización de la versión 3.1.x.x hacia 3.2.x.x. La pagina principal presento alguno imperfecciones de diseño. Adjunto imagen.


Primer problema, como pueden observar en la parte superior que yo remarque de manera un poco imperfecta con color rojo, sale una franja blanca con la leyenda “costos,gestión” quisiera saber como debería hacer para poder eliminar.

Segundo problema, algunas archivos que subimos antes de actualizacion presentan el siguiente error. adjunto imagen


las palabras presentan un signo de interrogacion. Antes de la actualizacion no presentaban ningun tipo de error.
saludos, gracias

Hi @Nicolas_Villegas,

The “costos, gestion” words are entered in the “Custom Tags” field; you can resolve that by removing them (or changing how they’re entered).

For the ? marks appearing in place of accented characters, see e.g.: OJS doesn’t recognize the non-English alphabets (for example Arabic or Turkish alphabets )

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like

Good I was reading the indicated posts and I can not find a solution. any recommendation to start?

Hi @Nicolas_Villegas,

Essentially, ensure that your database was created with the default character set specified as UTF-8, and make sure that you didn’t inadvertently change your character set related options in config.inc.php during the upgrade process.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher, these are the settings that are in my config.inc.php files.
they are correct? or should I change something?

;;;;;;;;;;;;;
; Localization Settings ;
;;;;;;;;;;;;;;;;;;;;;;;;;

[i18n]

; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = utf8

; Database storage character set
; Must be set to “Off” if not supported by the database server
database_charset = utf8

Hi @Nicolas_Villegas,

Those settings look fine to me, but are those the same settings that you used in the older version of OJS? It’s possible that the data is stored differently because the old installation used different settings.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher, after analyzing all the ojs, the settings before and after the update are the same.
What we saw is that only some files (3 files) have this irregularity, all the other files are correct. In the Database they are loaded correctly.
What could be done in this case?

image attachments

Hi @Nicolas_Villegas,

I suspect that if you look at the database directly (submission_settings with setting_name='title') for those submissions, you might find irregularities in the character set encoding – it’s interesting that the examples you include have some accents without trouble and others that seem to be illegal UTF-8. You might need to log in via a command-line database client rather than using a web-based tool, just to reduce the number of intermediate layers that might affect what you see – it’s sometimes tricky to get the database’s contents accurately when interim layers like terminal emulators might be intercepting and dealing with bad data.

Regards,
Alec Smecher
Public Knowledge Project Team