Facing an Issue in installation

Description of issue or problem I’m having:
I’m facing an issue “The directory specified for uploaded files does not exist or is not writable.”
I have created a folder in public_html named as files and have all the permissions (777) but it’s still not working. What should I do??
Can any of you can help me? I can provide you my hosting details if any of you can help me to install it

Steps I took leading up to the issue:

What I tried to resolve the issue:

Application Version - e.g., ojs-3.3.0-8.tar

Additional information, such as screenshots and error log messages if applicable:

What do you write to the file path:
if your “files” folder is in the public_html
your file path must be like:

or something like that (depending on server/hosting settings)

Hi all,

Beware that there are at least 2 security risks here!

  • The files directory should not be inside the web root unless it is protected from direct access using a .htaccess file or equivalent. Failing to protect it will lead to malicious code being executed on your server!
  • 777 permissions are never safe to use! They can be helpful for testing, but be sure not to leave them that way.

There is more information under the “Recommended Configuration” section in docs/README.md.

Alec Smecher
Public Knowledge Project Team

1 Like

This topic was automatically closed after 9 days. New replies are no longer allowed.