Error with Payment and author fee configuriation after upgrade to OJS 3.1


After upgrading from 2.4.7 to 3.1.0 ( updated with the most recent patch released on GitHub under ojs-stable-3_1_0 branch.) there is an error when I try to configure Payment options.

I want configure the journal for applying author fee on submission.

Here is what happens: (see attache image)OJS3-error

I go to Settings > Distribution > Payment then I

  • check the option
    Payments will be enabled for this journal. Note that users will be required to log in to make payments
  • choose the “Paypal Fee Payment” option
  • file in configure PayPl fields.
  • Save

After saved, I see a new button named “Payment” appear in left menu.
Clicking on that button I receive an erro 404 (page not found)

The url that gives the error is this:

In the Apache error_log I see these errors:
[Tue Nov 07 16:07:37 2017] [error] [client] ojs2: 404 Not Found, referer: http:/

Thank you in advace for your help

1 Like

I’d like to raise the same question. I’m also running into the same 404 Error on the {Payments}-tab with the most recent OJS3 build (from the master git branch)

Thanks in advance!

Hi all,

@razzi, can you pull down the latest ojs-stable-3_1_0 code? It’s likely that you’re running into a problem that’s already been fixed.

@mlfct, what URL are you seeing that 404 message for?

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

thank you for the quick follow up!

The URL is http://[baseurl]/index.php/journalname/payments#payments . Apparently the same problem url as razzi .

The apache error.log also just reports

[Mon Nov 20 20:27:30.188343 2017] [:error] [pid 15102] [client] ojs2: 404 Not Found, referer: http://xxx/index.php/xxx/submissions

Hi @mlfct,

Ah, you’re right. I moved a few files around on my git checkout and forgot to re-add and commit them. Please pull down a recent checkout of either master or ojs-stable-3_1_0 and the issue should be corrected.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

thank you - your latest commit fixed that issue. I noticed something else though:

When i head to My Subscription page ( /user/subscriptions ), the “purchase new subscription” option never appears, although it is activated in the backend. I also tried de- and reactivating the journal payment option, but it didn’t help.

After looking at the corresponding template in userSubscriptions.tpl, i noticed, that only the if-statements for $journalPaymentsEnabled wouldn’t appear. So i guess that template never receives that variable or it still is set to false somehow ?

As it seems to relate to the payment, i did not want to open another issue/thread.

Hi @mlfct,

Are you sure that your payment plugin is fully configured? Make sure that its setup fields have something entered.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

sorry to keep bothering you. Hope it is not an user error on my side. The payment plugin is fully configured, as far as i can tell.

I did some further tests and was able to narrow it down a bit: As i am running a custom template, i had to do some edits to the templates. As soon as i remove the custom subscriptions.tpl & userSubscriptions.tpl file from the template overrides (inside my custom template), the “Purchase New Subscription” Option reappears. The same behaviour also occurs, if i use the original template code inside the override directory.

I also did a quick test with the default theme and added the subscriptions.tpl to templates/frontend/pages/ . Even there the purchase option vanishes.

But maybe i am just completely missing the point on something…

Thanks for your answer, @asmecher

After downloading and installing the latest ojs-stable-3_1_0 branch,
the problem is solved


Rino Razzi