Error when upgrading from OJS 3.3.0-11 to OJS 3.4.0-3

Dear OJS team,

the upgrade to OJS 3.4.0-3 failed with this error:

2023-09-01 09:50:55 [migration: APP\migration\upgrade\v3_4_0\I7014_DoiMigration]
2023-09-01 09:51:01 [revert migration: APP\migration\upgrade\v3_4_0\I7596_RemoveNonExpiring]
2023-09-01 09:51:01 [revert migration: APP\migration\upgrade\v3_4_0\I7264_UpdateEmailTemplates]
2023-09-01 09:51:02 [revert migration: APP\migration\upgrade\v3_4_0\I4235_OAISetSpec]
2023-09-01 09:51:02 [revert migration: APP\migration\upgrade\v3_4_0\I6807_SetLastModified]
2023-09-01 09:51:02 [revert migration: PKP\migration\upgrade\v3_4_0\UpgradeMigration]
2023-09-01 09:51:02 [revert migration: PKP\migration\upgrade\v3_4_0\FailedJobsMigration]
2023-09-01 09:51:02 [revert migration: APP\migration\upgrade\v3_4_0\MergeLocalesMigration]
2023-09-01 09:51:02 [downgrade for “APP\migration\upgrade\v3_4_0\MergeLocalesMigration” unsupported: Downgrade not supported]
ERROR: Upgrade failed: DB: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘1–registrationAgency’ for key ‘doi_settings.doi_settings_unique’ (SQL: insert into doi_settings (doi_id, setting_name, setting_value) values (1, registrationAgency, DataciteExportPlugin))

After the upgrade attempt, the doi_settings table is filled with crossref entries. Apparently the updater tried to write something into doi_settings a second time, which is not allowed.

We have not been using Datacite for some time, but Crossref.

I tried uninstalling the datacite plugin before, that has no effect.

Could you help me?

Best Regards

Hi @rcgillis ,
I meant the newest OJS-Version, 3.4.0-3

Oh, okay - sorry - my mistake - thanks for clarifying.


Hi @rcgillis ,

this error also occurs with OJS 3.4.0-2 and also with another OJS installation I have.

In the submission_settings there was within a submission parallel to the setting_name “datacite::status” also “crossref::status”, both with the value “registered”.
Apparently the upgrader then tries to fill the doi_settings table with values a second time, which then goes wrong.
So as a workaround I deleted these (anyway old) datacite entries → update goes through.

This topic was automatically closed after 47 hours. New replies are no longer allowed.