Error Upgrade OJS 2.4.8 to 3.1.1-4

I have another problem with another site with OJS 2.4.8, it is a scientific journal and it has 100 numbers. the backup SQL file is 170mb. and of course upload it Hosting is very expensive. The problem starts when the update is made to OJS 3.1.1-4. the first time once I start the update it takes 2 hours for the process and finally I throw a blank page. And of course the databases were not updated correctly. Then perform from a local test server. and it takes 1 hour, with the same result. does not complete the update of the databases. I do not know if it’s because of the volume of information in the databases. When entering the site after the error shows me the content, entering the administration loads everything normally but the OJS version says that version 2.4.8 is installed

Is there any way to do the migration, loading the system clean and then uploading the scientific journals? Of course it would be too long to do so, but it has not worked for me at once.

Is there any way to update the databases manually?

Hi @dragoniant

Are you upgrading in Browser mode or in CLI terminal?
Despite so great size of your DB what may take more time is your files_dir folder upgrade.

Please, have a try with:
$ ojs-folder/ php tools/upgrade.php upgrade

It may be easier to handle such data amount this way.


Hi @israel.cefrin

I’m upgrading in browser mode. i don´t know how to do it in CLI terminal.

Hi @dragoniant

To upgrade using CLI you will need to have permission to run php in terminal.
You will follow same steps to install via browser, but to run installation process you will need run following command from your ojs-folder:
my-user@computer ~/ojs-folder $ php tools/upgrade.php upgrade