Error menu archives after upgrade OJS 3.1.1

Hi all

Recently i installed the version 3.1.1 OJS evrything is fine except when i give click in the link archives it show this error and blank page.

Fatal error: Uncaught Error: Call to a member function getPageCount() on array in /home/ojs/revistas/cache/t_compile/212833ef87fa1fc65e4bb561b9efd6bd26c984b5^%%6B^6B5^6B5271FB%%issueArchive.tpl.php:6 Stack trace: #0 /home/ojs/revistas/lib/pkp/lib/vendor/smarty/smarty/libs/Smarty.class.php(1257): include() #1 /home/ojs/revistas/lib/pkp/classes/template/ Smarty->fetch(‘frontend/pages/…’, NULL, ‘212833ef87fa1fc…’, true) #2 /home/ojs/revistas/lib/pkp/lib/vendor/smarty/smarty/libs/Smarty.class.php(1107): PKPTemplateManager->fetch(‘frontend/pages/…’, NULL, ‘212833ef87fa1fc…’, true) #3 /home/ojs/revistas/lib/pkp/classes/template/ Smarty->display(‘frontend/pages/…’, NULL, NULL) #4 /home/ojs/revistas/pages/issue/ PKPTemplateManager->display(‘frontend/pages/…’) #5 /home/ojs/revistas/lib/pkp/classes/core/ IssueHandler->archive(Array, Object(Request)) #6 /home/ojs/revistas/lib/pkp/classe in /home/ojs/revistas/cache/t_compile/212833ef87fa1fc65e4bb561b9efd6bd26c984b5^%%6B^6B5^6B5271FB%%issueArchive.tpl.php on line 6

thank you for the help

Hi @christian_criollo,

What theme are you using? If it’s Bootstrap, I believe a new release has just been put up on its repository.

Alec Smecher
Public Knowledge Project Team

Hello asmecher

The problem was the plugin bootstrap theme 3, I download the latest version (1.1.1) in this page Releases · NateWr/bootstrap3 · GitHub and replace the plugin in the folder plugins/theme and now is work correctly thank you very much for your attention

hi @asmecher,
I am also having same problem and i downloaded the latest version of bootstrap (1.1.2) and now it is working perfect but i am using child theme in that its showing blank page while clicking archive.
kindly give some suggestion.

Hi @sram,

Check your PHP error log for details.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,
Thanks for your reply. In my error log

PHP Fatal error: Uncaught Error: Call to a member function getPageCount() on array in C:\xampp\htdocs\ojs\cache\t_compile\b1833e07cde48b95bfa6dfe66d9ad2430979a526^%%6B^6B5^6B5271FB%%issueArchive.tpl.php:6\nStack trace:\n#0 C:\xampp\htdocs\ojs\lib\pkp\lib\vendor\smarty\smarty\libs\Smarty.class.php(1257): include()\n#1 C:\xampp\htdocs\ojs\lib\pkp\classes\template\ Smarty->fetch(‘frontend/pages/…’, NULL, ‘b1833e07cde48b9…’, true)\n#2 C:\xampp\htdocs\ojs\lib\pkp\lib\vendor\smarty\smarty\libs\Smarty.class.php(1107): PKPTemplateManager->fetch(‘frontend/pages/…’, NULL, ‘b1833e07cde48b9…’, true)\n#3 C:\xampp\htdocs\ojs\lib\pkp\classes\template\ Smarty->display(‘frontend/pages/…’, NULL, NULL)\n#4 C:\xampp\htdocs\ojs\pages\issue\ PKPTemplateManager->display(‘frontend/pages/…’)\n#5 C:\xampp\htdocs\ojs\lib\pkp\classes\core\ IssueHandler->archive(Array, Object(Request))\n#6 C:\xampp\htdocs\ojs\lib\pkp\classes\core\PKPPageRo in C:\xampp\htdocs\ojs\cache\t_compile\b1833e07cde48b95bfa6dfe66d9ad2430979a526^%%6B^6B5^6B5271FB%%issueArchive.tpl.php on line 6, referer: http://localhost/OJS/index.php/art/index

in my error log.

Hi @christian_criollo,

Are you using the manuscript theme plugin? There’s a new version that should resolve this.

Alec Smecher
Public Knowledge Project Team

I got the same error but the plugin theme I am using is OlgGregg, somebody can help me to solve this?

Call to a member function getPageCount() on array in /datos/servicios/www/revistas/cache/t_compile/f66927e784c208f8ece0b3df96fabeb6da725ad3^%%6B^6B5^6B5271FB%%issueArchive.tpl.php on line 6

Hi @EduardoOsquel,

I’d suggest contacting that theme’s author.

Alec Smecher
Public Knowledge Project Team

Solved my friend!! Thanks @asmecher

1 Like

How did you solve? I am getting similar

I upgraded from to 3.1.2 or similar. After this everything is working, except that Archives does not show archive folders. I also do not find the submissions recently made.


Hi @nainrs,

Was the update process successful?
Are there any relevant errors in PHP log associated with this problem?

Do you mean that they disappeared from the dashboard?

Thank you for your response. Actually the upgrade was successful. Now if i click on archive, it show error and doesn’t display old folders. Can you help?

You’ll need to explore PHP logs on relevant errors to find the reason of the issue. If you use shared hosting, ask you provider about how to find those logs.