Error 500 after updating CustomLocalePlugin

Hello,
After updating in ojs 3.2.1-1 the CustomLocalPlugin I obtain an error 500 when I try to access my site


the PHP log error is :
[15-Nov-2020 10:28:36 Europe/Berlin] PHP Strict Standards: mktime(): We selected ‘Europe/Berlin’ for ‘CET/1.0/no DST’ instead in /homepages/6/d452256660/htdocs/ojs3/lib/pkp/lib/vendor/adodb/adodb-php/adodb-time.inc.php on line 1091
[15-Nov-2020 10:28:36 Europe/Amsterdam] PHP Fatal error: Uncaught Error: Call to a member function getId() on null in /homepages/6/d452256660/htdocs/ojs3/plugins/generic/customLocale/CustomLocalePlugin.inc.php:32
Stack trace:
#0 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/plugins/PluginRegistry.inc.php(69): CustomLocalePlugin->register(‘generic’, ‘plugins/generic…’, NULL)
#1 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/plugins/PluginRegistry.inc.php(144): PluginRegistry::register(‘generic’, Object(CustomLocalePlugin), ‘plugins/generic…’, NULL)
#2 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/core/Dispatcher.inc.php(132): PluginRegistry::loadCategory(‘generic’, true)
#3 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/core/PKPApplication.inc.php(279): Dispatcher->dispatch(Object(Request))
#4 /homepages/6/d452256660/htdocs/ojs3/index.php(68): PKPApplication->execute()
#5 {main}
thrown in /homepages/6/d452256660/htdocs/ojs3/plugins/generic/customLocale/CustomLocalePlugin.inc.php on line 32
[15-Nov-2020 10:28:43 Europe/Berlin] PHP Strict Standards: mktime(): We selected ‘Europe/Berlin’ for ‘CET/1.0/no DST’ instead in /homepages/6/d452256660/htdocs/ojs3/lib/pkp/lib/vendor/adodb/adodb-php/adodb-time.inc.php on line 1091
[15-Nov-2020 10:28:43 Europe/Amsterdam] PHP Fatal error: Uncaught Error: Call to a member function getId() on null in /homepages/6/d452256660/htdocs/ojs3/plugins/generic/customLocale/CustomLocalePlugin.inc.php:32
Stack trace:
#0 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/plugins/PluginRegistry.inc.php(69): CustomLocalePlugin->register(‘generic’, ‘plugins/generic…’, NULL)
#1 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/plugins/PluginRegistry.inc.php(144): PluginRegistry::register(‘generic’, Object(CustomLocalePlugin), ‘plugins/generic…’, NULL)
#2 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/core/Dispatcher.inc.php(132): PluginRegistry::loadCategory(‘generic’, true)
#3 /homepages/6/d452256660/htdocs/ojs3/lib/pkp/classes/core/PKPApplication.inc.php(279): Dispatcher->dispatch(Object(Request))
#4 /homepages/6/d452256660/htdocs/ojs3/index.php(68): PKPApplication->execute()
#5 {main}
thrown in /homepages/6/d452256660/htdocs/ojs3/plugins/generic/customLocale/CustomLocalePlugin.inc.php on line 32

Can you help me?

When I ugrade my site to version 2.3.1-2 the problem is solved and my site can be accessed.

1 Like