Emails not sending out from OJS site

I run 4 different OJS journals. At this time, one of the journals will not send out any emails. This is a new issue- the journal has been normal with emails in the past. Now, the site makes seems as though the email is being sent out (all processes are normal, email log is normal) but nothing is received on the other end.

How can I try to fix this issue?

Hi @mde06,

OJS sends emails via one of two mechanisms, depending on your configuration: either PHP’s built-in mail() function, or an SMTP server as configured in Either service might refuse to deliver a message without telling OJS.

Are you using a recent release of OJS? We’ve made some changes in how emails are delivered that might be relevant.

Alec Smecher
Public Knowledge Project Team

Thanks Alec.

I am running OJS

Hi @mde06,

The problem is likely Sender Protection Framework policies, which mail servers use to help ensure that emails are trustworthy. We made some changes in OJS 2.4.6 to better follow these policies. You’d need to check your mail server’s sending logs to know for sure why OJS’s emails weren’t being delivered, but I suspect upgrading to OJS 2.4.6 would likely resolve the problem.

Here’s the bug entry for the changes:

Alec Smecher
Public Knowledge Project Team

Thanks very much. We will try upgrading.

I use new version 2.4.8 but this still happened. What I supposes to do ?

@Novi_Hidayati, you’ll need to identify which mechanism (SMTP or php’s mail()) you are using for sending, and then begin debugging there.

For example, if your has SMTP turned off, you (or the sysadmin) can look in the local mail server logs for details. If SMTP is turned on, you will need to have that server’s administrator check the logs and report whether mail appears to be sent off-system successfully.

Recipients should check their “Junk” or “Spam” folders in case messages are being caught there. If so, there is usually a way to add the sender to a “safe senders” list.

SMTP , old case already solved . But now after system updated whole jurnal cannot send email.

For an in-depth discussion of recent changes, see this discussion here:

and possibly here:

There is no change in config … everything exactly same like before upgrade. Server work fine , but still cannot sent email and I don’t know why

You will need to look into the logs to identify where the process is breaking down. This is described in the thread I linked earlier. I also detail this workflow here: