Emails do not sent

Good day,

I have just noticed that on my OJS3 emails for password reset (and all other kinds) do not sent at all. But on my test site on other server all works fine.

Could you please give advice what should I check in the first place?

to be more specific, from mail logs I see:

    Sep 24 17:40:53 myservername sendmail[18362]: u8OEeqj1018362: Authentication-Warning: www-data set sender to using -f
    Sep 24 17:40:53 myservername sendmail[18362]: u8OEeqj1018362:, size=1892, class=0, nrcpts=1, msgid=<>, relay=www-data@localhost
    Sep 24 17:40:53 myservername sm-mta[18363]: u8OEerrc018363: from=<>, size=2123, class=0, nrcpts=1, msgid=<>, proto=ESMTP, daemon=MTA-v4, []
    Sep 24 17:40:53 myservername sendmail[18362]: u8OEeqj1018362: to=Doc <>, (33/33), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31892, relay=[] [], dsn=2.0.0, stat=Sent (u8OEerrc018363 Message accepted for delivery)
    Sep 24 17:50:22 myservername sm-mta[18321]: u8OEJrwc017853:, delay=00:28:07, xdelay=00:10:37, mailer=esmtp, pri=210013, [], dsn=4.0.0, stat=Deferred: Connection timed out with`

port scan with nmap:

25/tcp open smtp

Problem solved. My internet provider closed port 25. Its rediculous but even after my call they told me the opposite. However this information was on their site. So to avoid further confrontation I simply changed port connection to my email account and all worked.

1 Like