Email not received from Journal manager B email ID

We have two Journal managers ID A and B against one journal. When journal manager A sends email ( to all associated user, everybody receiving that mail from A. But journal manager B send email ( to same group of user account then email not delivered from B. Why? Is there any specific email setup to differentiate, A and B?

What version of OJS are you using, and what is your email setup in


Thanks for replay,

I am using 2.4.8 version of OJS.

And Email setting in file mention below:-

; Email Settings ;


; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = “tls://”
smtp_port = 587

; Enable SMTP authentication
; Supported mechanisms: PLAIN, LOGIN, CRAM-MD5, and DIGEST-MD5
smtp_auth = PLAIN
smtp_username = “
smtp_password = “##########”

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
allow_envelope_sender = On

; Default envelope sender to use if none is specified elsewhere
default_envelope_sender = “

; Enable attachments in the various “Send Email” pages.
; (Disabling here will not disable attachments on features that
; require them, e.g. attachment-based reviews)
enable_attachments = On

; Amount of time required between attempts to send non-editorial emails
; in seconds. This can be used to help prevent email relaying via OJS.
time_between_emails = 3600

; Maximum number of recipients that can be included in a single email
; (either as To:, Cc:, or Bcc: addresses) for a non-priveleged user
max_recipients = 10

; If enabled, email addresses must be validated before login is possible.
require_validation = Off

; Maximum number of days before an unvalidated account expires and is deleted
validation_timeout = 14

Please reply me ASAP.

So, it seems like mail from is being blocked when sent from’s account (as per the SMTP settings).

I would suggest turning off allow_envelope_sender and then testing mail again. Does this allow for sending? Who does the mail end up being “from”… abc or xyz?

Another approach would be to update to 2.4.8-1 and apply the change described here:
Then, set “allow_envelope_sender” and “force_default_envelope_sender”.

Does this allow for sending? Who does the mail end up being from? Does the reply-to address function as expected?