Editor getting error when trying to download revised files

Hello - using OJS 3.3.06

We have a submission that has been in the system. It went to review and then revisions were requested. Revisions were uploaded then deleted and re-uploaded.

The roles Journal Editor and Section Editor cannot seem to download these revised files. Upon clicking, they receive this error:
{“status”:false,“content”:“You have not been assigned to this submission with a role that is allowed to access this operation.”,“elementId”:“0”,“events”:null}

I have tried re-assigning the editor to the role and that did not work. I tried re-assigning as Journal Manager, and this role gets the same error.

Any suggestions on why this might be happening or what I might need to look at?

Screen Shot 2021-06-23 at 11.42.05 AM

Thank you!

Hi @hxo82,

It looks as though another user has encountered a similar error (and a potential solution) here: OJS 3 mixing of editor and reviewers role - #4 by primozs - perhaps you could try what they’ve done there.

PKP Team

Thank you @rcgillis!

Before moving to the database, we ended up clearing cache on one user’s machine, which worked in that instance.

Then, we went into admin tools and expired all user sessions. This solved the problem for the other user.

It may have been a cache issue with the system trying to look for the deleted file the revision had replaced.

Just adding this as something to explore if anyone else experiences this problem!

Ah - thanks for sharing how you resolved this, @hxo82!

Sometimes clearing the the caches works wonders!

PKP Team

1 Like

This topic was automatically closed after 23 hours. New replies are no longer allowed.