Doesn't save changes articles

Description of issue or problem I’m having:
When I make some changes in unassigned articles I got errors:

The form was not saved because 1 error(s) were encountered. Please correct these errors and try again.

Please correct one error. Go to Abstract: Please enter the abstract of your article. Jump to next error

But if I enter the abstract I get the same error.

In Chrome DevTools I see error:
jquery.min.js?v=3.3.0.7:2 POST http://kired.v913375d.beget.tech/index.php/journal/api/v1/submissions/52/publications/52 400 (Bad Request)

Steps I took leading up to the issue:

I unpublish the article from publication so that I can edit it. All articles are uploaded via import from XML.

What I tried to resolve the issue:

I turned on debug mode in Config.inc.php

Application Version - e.g., OJS 3.1.2:
OJS 3.3.0.7

Additional information, such as screenshots and error log messages if applicable:
Снимок экрана 2021-11-21 в 16.12.43

I solved that issue. Problem was in blank columns “locale” in “submissions” table. All values in the column had “NULL” value instead “en_US” (or any default langue of submissions). I don’t know why the import plugin didn’t fill these values when I upload data.
It’s definitely bug.

2 Likes