Dataverse plugin in ojs 2.4.8

Hi! I am trying to install the OJS Dataverse Plugin, but I can’t seem to get past the dataverse connection. I always get a “Dataverse Network URL is not valid.‎” error. I have an Open Journal Systems‎ installed in my website. My dataverse account is in Did anybody encounter a similar problem?

Hi Chip,

You’ll need to authenticate with an API key in order to connect to the Harvard Dataverse. Username/password authentication is only supported for connecting to older, version 3 Dataverses.

Let me know if that’s not the problem.


1 Like

Hi, Jen. Thanks. I tried that too, but it didn’t work. For giving the URL
and the API (without password), the OJS would return a URL error and a
missing password error.

Hi again, Jen! After replying to your post, I gave the API approach one more try, and it worked after I used a re-generated API! Thanks, big time Jen!


@chip I’m glad you figured it out! @axfelix and I had been discussing it at IRC log for #dataverse, 2016-05-02 and I’m glad to know it’s working for you.

Heads up to @jwhitney and @axfelix that I’m hoping to start looking at SWORD: More granular permission checks · Issue #1070 · IQSS/dataverse · GitHub soon-ish.

@chip you’re welcome! (and thanks for the irc link, @pdurbin)

Glad to hear the OSF folks are motivating that work

Big thanks again, @pdurbin and @axfelix!