CrossRef Export/Registration Plugin - Export Data

I am using OJS- and have discovered an issue with the CrossRef Export/Registration Plugin.

When I export All Issues I am only getting the first page of 60 items.
This one journal has 272 items which is 5 pages of data but I have no way of going past page 1.

Does someone have a fix for this problem. We have a number of DOI’s that have the wrong URL and need to have them exported and resent to Crossref ASAP.


Hi @EdwardDavid,

The “Select All” only refers to items on the current page. You’d either have to run through each page separately, or you can temporarily edit the number of items per list on Journal Setup, page 5, to include all items in one page.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,
When I bring up the old journal in OJS-2.4.3.
It has CrossRef XML Export Plugin with Export Issues.
I have the capability of looking at 5 pages of items.

I did try your suggestion to temporarily edit the number items per page and set this to 300.
I ended up with a blank page so that did not work.

So how do I see the past issues. I would think it should allow multiple pages of items.


Hi Edward,

I think the memory limit error appears here – it is too much processing. So I would suggest that you export page per page.


I think what Edward is saying is that he doesn’t even see the pager on the “Export Data” → “All Articles” page. That sounds vaguely familiar as a recently fixed bug. But I can’t find the commit in recent Git history, and I can’t replicate the issue in 2.4.7-1, so I may be imagining it.


You are correct I am not seeing the pager on the “Export Data” → “All Articles” page.
The issue exists and I am on OJS-

So is there a patch for this issue.


I was unable to find the original bug I “remembered” and I cannot replicate the issue in the current release. Do you have any local modifications to your install?

If you use the “Export Data” → “All Issues” function do you see the expected Article counts associated with the Issues? Does using the Register function there work?

i still believe that it’s a memory problem, i will search a similar issue on the old forum… because every article is searched though if it has the doi, to be displayed in that list… i am of course not 100% sure, but…


There is no local modification for this particular journal installation.

When I use “Export Data” → “All Issues” all I am seeing is 1 - 60 of 60 Items.
When I should be seeing 1 - 60 of 272 Items. The Register function works if I select an issue I can export the data…

This was a full clean installation from OJS-2.4.7 and then a upgrade.php patch to OJS-

So not sure if that helps or not.



I just realized I was using the Export function and not the Register function.
So not sure at this point if the Register functions works or not.
Is there any harm in Registering an Item that has already been registered?


The Register function sends the XML directly to CrossRef. I assume with the Export function you are manually uploading the XML to CrossRef?

If already Registered, the Register function effectively performs an update with CrossRef. I’m not sure what all implications would come into play if you manually uploaded an Export to CrossRef and then Registered the same article(s) later. I suspect it would still be effectively an update, but I haven’t recently looked at the code to verify.

I was thinking on this issue: and hit of the maximum execution time – sorry, not memory :-\ – but it seems to work now…

It is definitely not working now…
I need this issue fixed so if a patch does exist please point me to it.


Hi Edward,

It should work if you export/register page per page with the normal items number (e.g. 25) in the setup 5.

If you increased the number in the setup 5 and see a blank page you could get the maximum execution time.


I have tried the export with normal item number of 60 and tried 25 as well in setup 5.
I do not have any pages to go to. This plugin should be showing me x number of pages and it is not.
I am not interested in increasing the number of items to 280 or 300 and playing around with the maximum execution time.

That does not fix the code issue it is just a work around. I am not interested in a work around.
I need a path for the actual plugin so I can see multiple pages.

This is what I am seeing. There is not pages for me to go to. I have 273 items I should be seeing 5 pages.


I think this bug is still thre i.e. not fixed yet, I’ll take a look.

Sorry @ctgraham, you were right! :-\

The export that I did from the older system failed so was not able to add them to CrossRef.

So do you have an idea of when I can test this plugin with OJS-

The Journal Manager would really like to get these issues fixed.


You can track on the progress of this issue:

Hi @ctgraham,
I was wondering if pkp/pkp-lib#1088: fix issue display for the crossref plugin · bozana/ojs@a768e1a · GitHub
is a patch for this issue?

I tried to apply and got this patch and got this:
patch -p1 --dry-run < CrossRefBugFix.diff
checking file plugins/importexport/crossref/
Hunk #1 succeeded at 120 with fuzz 1.
Hunk #2 FAILED at 134.
Hunk #3 succeeded at 143 (offset -1 lines).
1 out of 3 hunks FAILED
checking file plugins/importexport/crossref/templates/issues.tpl


Yes, @EdwardDavid, that is the current patch being tested.

There are a number of updates to the Crossref plugin between 2.4.7-1 and the latest development. The ones that are probably causing Hunk #2 to fail in your patch are:


Try adding those two patches in order on a development copy. I think @bozana’s patch should be able to fuzz through after that.