Citation Style Language PlugIn erzeugt Fehler 500

plugin
error

#1

Liebes OJS-Forum,

ich bekomme seit kurzem ein Error 500 - also einen Serverfehler - wenn ich auf einzelne Artikel klicke. Er zeigt mir an, dass er die Vorschauseite nicht finden kann. Interessanterweise passiert dies nicht, wenn ich den Artikel als PDF direkt abrufe.

Ich verstehe nicht ganz wo der Fehler liegen kann, ob ich die ganze Ausgabe nun nochmal ins Netz stellen muss oder ob sich irgendwo ein PlugIn querstellt. Ich habe den Cache bereits gelöscht aber das hat leider auch nichts gebracht.

Danke für eure Hilfe


#2

Haha ich hab rausgefunden, woran es lag und zwar an dem PlugIn: Citation Style Language. Immer wenn dieses aktiviert ist, kann ich die einzelne Artikeldarstellung nicht mehr anklicken bzw. es kommt zu einem Serverfehler. Kann mir jemand sagen, wie ich diesen beheben kann?


#3

Wir haben das gleiche Problem - beim Aktivieren der CSL in OJS 3.1.0.0 sind die Frontdoor-Seiten leer. Die PDFs selbst können noch abgerufen werden (über die Table.of-Contents-Seite) Gibt es hierzu schon eine Info oder einen Bugfix? Ist das Problem evtl. in OJS 3.1.0.1 behoben?


#4

Wir haben jetzt auf OJS 3.1.0.1 aktualisiert, aber das Problem existiert weiterhin. Aktivierung einer Stils unter “Primäres Format für bibliographische Angaben” brachte keine Abhilfe.


#5

Lieber Felix,

der Fehler ist bereits gemeldet: OJS 3.1.0: Issue with "Citation Style Language" plugin
Es wird unter anderem Empfohlen die PHP-Upgrade durchzuführen. Dennoch sollte, wie hier im Beitrag beschrieben OJS 3.1.0: Issue with "Citation Style Language" plugin der Nachname des Autors in den Metadaten der Einreichung angegeben werden. Danach sollten die Zitationsstile wieder auf der Artikelseite angezeigt werden. Gerade in Test-Umgebungen lässt man gerne mal den Nachnamen Weg, weil man die Funktionen als Admin durchführt.

Viele Grüße

Tahsin


#6

Lieber Tahsin,

vielen Dank für deine Hilfe. Aber irgendwie beibt der Fehler bestehen. Ich hatte bereits PHP 5.6 benutzt. Wenn ich auf PHP 7.1. upgrade, dann wird OJS gar nicht mehr angezeigt, da es diese PHP-Version gar nicht unterstützt. Also ich schaue nochmal mit den Nachnamen aber eigentlich hatte ich die auch angegeben. Also es bleibt kompliziert.