Can't upload new galleys in an old article


I’m working with an OJS 3.2.1-1, and I need to upload a PDF galley to an article of a past issue, from almost 2 years ago, but when I check the galleys, it doesn’t show the galleys, nor the add galley button, instead it shows an spinner that goes forever.

someone has the same problem?, any ideas on how to correct the problem?

I already tried unpublishing the article, even the entire issue, but it doesn’t help.

Thanks in advance.

Captura de Pantalla 2020-12-02 a la(s) 10.22.03 p. m.

Hi @DiegoG,

Have you tried clearing the data and template cache in the Administrator settings? Have you checked your error logs to see if anything is flagged there? You can post your error log here that might help diagnose the issue further.


Public Knowledge Project Staff

I’m having a similar problem for an article I had to unpublish to replace the galley. I have cleared the data and template caches. There is an error log message:

[03-Dec-2020 16:36:23 Europe/London] PHP Fatal error: Uncaught Error: Call to a member function getFileId() on null in /home/qualifj1/public_html/ojs/lib/pkp/controllers/api/file/linkAction/
Stack trace:
#0 /home/qualifj1/public_html/ojs/lib/pkp/controllers/api/file/linkAction/ FileLinkAction->getActionArgs(NULL, 5)
#1 /home/qualifj1/public_html/ojs/controllers/grid/articleGalleys/ DownloadFileLinkAction->__construct(Object(Request), NULL, 5, ‘xml’)
#2 /home/qualifj1/public_html/ojs/lib/pkp/classes/controllers/grid/ ArticleGalleyGridCellProvider->getCellActions(Object(Request), Object(ArticleGalleyGridRow), Object(GridColumn))
#3 /home/qualifj1/public_html/ojs/lib/pkp/classes/controllers/grid/ GridCellProvider->render(Object(Request), Object(ArticleGalleyGridRow), Object(GridColumn))
#4 /home/qualifj1/public_html/ojs/lib/pkp/classes/controllers/grid/ GridHandler->_renderCellInternal in /home/qualifj1/public_html/ojs/lib/pkp/controllers/api/file/linkAction/ on line 46

I’m running version with php 7.2.34. The only thing I’ve noticed is that the date of the production ready file is in red text.


Any advice would be gratefully received.