Can't update Crossref plugin


Our instance of OJS (v. has a rather outdated version of the CrossRef plugin (

The plugin has no update option in the gallery, so I downloaded the current version from GitHub, targunzipped it and tried to upload it – but I got a The uploaded plugin does not fit the category of the upgraded plugin error.

I then tried to swap the directory directly, causing the entire plugin page to fail with a PHP Fatal error: Uncaught Error: Class 'APP\\plugins\\generic\\crossref\\CrossRefPlugin' not found.

What am I missing?

Ok – I’m confused.

The README file says 2.1 – and it’s the same version as mentionned in the README file on GitHub.

However, the version.xml on GitHub says :


While our version says:


Hi @nicolasd,

The version numbers (CrossRef at 2.1.0 and OJS at 3.3.0-13) aren’t meant to align. Stick with the version of the CrossRef plugin that came with your OJS; the current Github main branch is not compatible with your OJS. It’s intended for release with OJS 3.4.0.

Alec Smecher
Public Knowledge Project Team

1 Like

This topic was automatically closed after 9 days. New replies are no longer allowed.