Can't show Creative Commons License

Im trying to get this, but im not sure how
48

Hi @mmellaa

I think this is not the default OJS – maybe they changed/added it so…
If your issues are always having the same license, you could also add the code in the OJS smarty template, e.g. somewhere here: ojs/issue.tpl at ojs-stable-2_4_8 · pkp/ojs · GitHub, or else write a plugin that would display it…

Best
Bozana

This is only an example. How is the default way?
I dont know

El El lun, 31 de jul. de 2017 a las 12:16, Bozana Bokan <
pkp@forum.pkp.sfu.ca> escribiĂł:

Hi @mmellaa

They are not displayed under the issue TOC at all – they can be displayed on the article page, if so configured in journal Setup 3.2 Permissions and if the license is entered in the article metadata.

Best,
Bozana

I have set it up in 3.2, but i cant see it in the article. How can i
checked the metadata? where should i see this license?

Hi @mmellaa

As editor you should go to an article (e.g. Back Issues > issue > article) and then there on the article summary view page > Submission Metadata > Edit Metadata.

You should see the license on the article abstract and galley (full text) page, e.g. like here:
http://www.hin-online.de/index.php/hin/article/view/251
http://www.hin-online.de/index.php/hin/article/view/251/466

If you configured the setup 3.2 after the articles have been published, you will have to save each article metadata anew or use the button “Reset Article Permissions” in the setup 3.2, that will assign that license to all articles.

Best,
Bozana

I revised the metadata and the info is correct, but i still cant see the
info on the article

Hmmm… That sounds strange… What OJS version are you using? Could you maybe send the screenshots of your 3.2 setup configuration, article metadata and maybe the link to the article view page where the license should appear?

OJS 2.4.8-2
And i attached the screen shot of my 3.2 setup

Hi @mmellaa

And how do your article metadata license filed look like? – Does it contain the URL and are the metadata saved so?

Best,
Bozana

Where do i see that??

El El lun, 14 de ago. de 2017 a las 05:40, Bozana Bokan <
pkp@forum.pkp.sfu.ca> escribiĂł:

Hi @mmellaa

Go as editor to an published article and its metadata, e.g. editor home page > Back Issues > choose an issue > choose an article > Submission Metadata part of the article Summary page > EDIT METADATA.
Ensure that the filed License URL is filled and metadata saved.

Best,
Bozana

The article link is:
http://www.summapsicologica.cl/index.php/summa/article/view/203
And the metadata is the capture included

Hi @mmellaa

Your settings (jorunal setup 3 as well as article metadata) seem to be correct.
It seems like your installation is using some other, customized templates (and not the original, default ones). Here is how the original template code for license display in the article footer looks like: ojs/footer.tpl at ojs-stable-2_4_8 ¡ pkp/ojs ¡ GitHub. Could you or your web admin check if your template contains that code as well?

Best,
Bozana

1 Like

Hi you all.

Same problem here.
Articles already existing before upgrade (2.4.8.0) shows CC icon, news articles no.
After reset permissions (journal/management/settings/distribution) not showing even in before-upgrade articles.

In database, before reset subimission_settings contains copyrightHolder, copyrightYear, licenseURL. After there is no permission setting.

Tarcisio Pereira.

Hello
I have check de code in /templates/article/footer.tpl and L41 to L54 is
exactly the same:

{if $currentJournal}
{if $currentJournal->getSetting(‘includeCopyrightStatement’)}



{translate key=“submission.copyrightStatement”
copyrightYear=$article->getCopyrightYear()|escape
copyrightHolder=$article->getLocalizedCopyrightHolder()|escape}
{/if}
{if $currentJournal->getSetting(‘includeLicense’)}



{if $ccLicenseBadge}
{$ccLicenseBadge}
{elseif $article->getLicenseURL()}
{translate key=“submission.licenseURL”}: {$article->getLicenseURL()|escape}
{/if}
{/if}
{/if}

Hi @mmellaa

Maybe the templates your installation is using are somewhere else?

The original OJS code to display DOI on the article page is:

<br>
<br>
DOI:
<a id="pub-id::doi" href="http://dx.doi.org/10.14766/1216">http://dx.doi.org/10.14766/1216</a>
<br>
<br>

S. e.g. source code from this journal article page: Rezension zu: Kathrin Baumstark: „Der Tod und das Mädchen“. Erotik, Sexualität und Sterben im deutschsprachigen Raum zwischen Spätmittelalter und Früher Neuzeit. Berlin u.a.: LIT Verlag 2016. | querelles-net

In your journal, the code is:

<div class="calugacontenidoint">
<h2 class="ajusteview">
<div class="inner">DOI:</div>
</h2>
</div>
<br>
<a id="pub-id::doi" class="ajusteleft" href="https://doi.org/10.18774/summa-vol13.num2-203">https://doi.org/10.18774/summa-vol13.num2-203</a>

S. e.g. the source code of this journal article page: http://www.summapsicologica.cl/index.php/summa/article/view/203

Also you have something like:

<div class="footer">
<div class="container">
<div class="row col-md-12">
<div class="row col-md-6 ajustefooter">

which does not exist in OJS.

I do not know where this code in your installation comes from, maybe you could search for it to figure out where is the code used in your installation – apparently the original OJS article/footer.tpl is not used…

Best,
Bozana

Hi @Tarcisio_Pereira

Which OJS version are you using? – It seems you are using 3.x?

Best,
Bozana

Hi @bozana

For this topic I’m using 3.0.2.0 with postgresql database.
I can’t upgrade my production before fix some problems like this one.

Regards,
Tarcisio Pereira.

Hi @Tarcisio_Pereira

The license display in OJS 3 functions slightly different: if you use the button “Reset Article Permissions”, it will only delete all licensing information saved with each article. @asmecher, is this supposed to be so in OJS 3?
Also an article will have to have the license information explicitly attached, which should be the case for migrated articles though.

Thus you should definitely revert to the initial update i.e. before you use that button. Then we should see why the license information for some articles is not displayed. Maybe you would need to apply this patch: pkp/pkp-lib#2640 fix copyright holder and year by bozana ¡ Pull Request #1450 ¡ pkp/ojs ¡ GitHub

Best,
Bozana

1 Like