Can't create or edit user's roles - Error ##user.profile.form.givenNameRequired## (English)

  • Application Version - OJS

  • Description of issue - When I try to create a new user from my Journal Manager account, a sign as the one attached appears. When I try to edit an already created user, the same happens.
    The problem seems to be the lack of “given name”, but as the image shows, there is a name with the user.

  • Steps you took leading up to the issue - Trying to edit roles or create new users always lead to the same.

  • What you tried to resolve the issue - To create new users, I created them from outside my account. But I can’t edit their roles.

Any idea on how to solve it?


Hi @Matias_Lopez,

The error says you have not filled the givenName in English. Have you done that?

Regards, Primož

Hi Primozs,

Thanks for the answer.

As the image shows, I think the name slot is filled. “Andrea”. Mayhaps I am not filling the correct slot?

Hi @Matias_Lopez,

Hm, do you have multiple languages? Canyou post here the screenshot of Settins-Website-Lanugages?

Regards, Primož

Hello everybody!

We have the same problem. Could you solved it?

Our OJS had two languages, but we deleted them (English and Spanish AR) and installed Spanish (ES).