Cannot add reviewers to a submission in 3.0

We are using with php version 5.6.32 [originally said 3.0 in error].

When we click on “Add Reviewer” we get the basic panel, but no longer get a list of potential reviewers. Furthermore the search functions within the panel do not work.

We have over 250 submissions, of which about 50 are in the “review” stage, so this function is essential. Does anyone have any ideas about what might be wrong? I have sufficient knowledge of php to edit the code, add debug statements, etc., but I don’t even know where to start looking? Could it be some corrupted data in the database that is causing the function to die but without generating any error notification?


Are you sure about your PHP version? PHP 3 is ancient :smiley:

And do you mean OJS 3.1.0 or OJS 3.0.1.? 3.0.1. is old and filled with bugs, so if you are still using it, then the best option would probably be to upgrade as soon as possible.

If the add reviewer button used to work, then it could be that one of the user accounts that is getting fetched there has some kind of corrupted data there which is breaking javascript. But this is just a guess…

Whoops! A big copy & paste error! The php version is: 5.6.32


1 Like

I would suggest to upgrade OJS. That function worked properly in OJS and 3.1.0-1.

1 Like

Hello. I upgraded to 3.1.0-1 as recommended but sadly it did not fix the issue that we were having with adding reviewers.AddReviewerIssue

None of the search options work.

Since we are getting the same result to two separate versions, I think that there is some bad data somewhere that is causing the ajax display to abort.

I could try placing some “echo” statements for debugging in the php file that processes this, but I’ve got no idea where that might be. I’m welcome to any suggestions!

Do you have in your installation of OJS users with role reviewer? Please check once more in Requiremenst for OJS do you have all libraries present on your server.

We have about 130 reviewers registered. The feature was working until the middle of December when it suddenly stopped. All of the libraries are present on the server:
-rw-r–r-- 1 teslejsu teslejsu 1458 Dec 2 05:53
drwxr-xr-x 3 teslejsu teslejsu 4096 Dec 2 05:53 api
drwxr-xr-x 53 teslejsu teslejsu 4096 Dec 2 05:53 classes
-rw-r–r-- 1 teslejsu teslejsu 656 Dec 2 05:53 composer.json
-rw-r–r-- 1 teslejsu teslejsu 93201 Dec 2 05:55 composer.lock
drwxr-xr-x 14 teslejsu teslejsu 4096 Dec 2 05:53 controllers
drwxr-xr-x 2 teslejsu teslejsu 4096 Dec 2 05:53 dtd
drwxr-xr-x 2 teslejsu teslejsu 4096 Dec 2 05:53 includes
drwxr-xr-x 7 teslejsu teslejsu 4096 Dec 2 05:55 js
drwxr-xr-x 8 teslejsu teslejsu 4096 Dec 2 05:54 lib
drwxr-xr-x 29 teslejsu teslejsu 4096 Dec 2 05:53 locale
drwxr-xr-x 18 teslejsu teslejsu 4096 Dec 2 05:53 pages
drwxr-xr-x 8 teslejsu teslejsu 4096 Dec 2 05:53 plugins
drwxr-xr-x 2 teslejsu teslejsu 4096 Dec 2 05:53 registry
drwxr-xr-x 8 teslejsu teslejsu 4096 Dec 2 05:53 styles
drwxr-xr-x 21 teslejsu teslejsu 4096 Dec 2 05:53 templates
drwxr-xr-x 2 teslejsu teslejsu 4096 Dec 2 05:55 tools
drwxr-xr-x 3 teslejsu teslejsu 4096 Dec 2 05:53 xml

It could be either reviewer data or the “ControlledVocabulary” that has something there that causes the process to choke. How can I go about debugging this issue?

1 Like

I did not think on folders but on libraries related to infrastructure such as readlib or so. What is your PHP error log regarding that issue?

We have nothing in the “Submission library” if that is what you meant. We haven’t done much except to use the plain vanilla version. We only use it for submissions, not for actual publication.

The error_log just keeps repeating these two lines although I had just tried to add a reviewer immediately prior to getting the error log:

[22-Jan-2018 04:19:38 America/Chicago] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/teslejsu/public_html/ejojs2/lib/pkp/classes/form/ on line 388
[22-Jan-2018 04:19:38 America/Chicago] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/teslejsu/public_html/ejojs2/lib/pkp/classes/core/ on line 592

I did not mention library as Submission library. Some software packages that should be on server are also called library. If some of them is missing or outdated you can experience difficulty as you have now.
As far as PHP error log is concerned I think that the best is to check with @asmecher and @bozana

Thank you. I’ll wait for their response. Actually, since it was working and we did not change any of the other areas on the server, all libraries should be present.

You could try two things:

  1. Change the php error logging settings so that the deprecated errors do not appear (I think that I use error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT)
  2. Check your javascript console when you open the modal window to add reviewers. Are there any javascript errors there?

Thank you. I’ll do that. I did turn on the verbose debugging in the which yielded this error message.

Does this help narrow down the cause?


1 Like

invalid JSON sounds a bit like malformed data, but hard to say. Try the two things I mentioned.

The Javascript console shows no errors. I’ve submitted a ticket to our hosting service to prevent the listing of deprecated warnings/errors.

You could check the user accounts of the reviewers that got registered as reviewers after the feature stopped working for you. The invalid JSON sounds like the system is trying to send the data, but there is some content that prevents it.

Also: does this happen with all submissions? We had last year a situation, where the abstract of one manuscript contained <12 and it lead to similar (not identical) problems.

Yes, it happens with all submissions.

I’ve eyeballed the entire user table – 288 entries, and didn’t see anything odd, although the cause could be an invisible character.

Are there any limitations on the controlled vocabulary settings. One person, for example, entered all this as one entry (setting_name = interest)

critical pedagogy; qualitative research methods; ethnography; reading and writing instruction; teacher training

The current input system does not properly parse strings like this into individual components.

I would need access to another computer of mine, but two more things you could check:

  1. Have you enabled an adblocker of some sort in December?
  2. Are the role settings for the reviewers role ok, I mean does the role have access to the reviewer stage (not probably it, but check anyway)

I can check this again later today when I can check what are the things that are called on that page. Can not do that right now. But maybe Alec answers before I do.

Thank you!! You’ve found the problem. Somehow the review role did not have “review” checked. I’m not sure how that could have happened. Certain not on purpose!

Anyway issue solved. Thank you all for your time!

There is still a small issue with the Logon Screen not appearing, but I’ll post a separate query about that.

Thank you again!


How did you solve it? I have the same problem. I can’t add any reviewer! It doesn’t work.

1 Like