Can`t create a journal. Path not found


I couldn’t find info on this topic.
I’ve just installed for the first time.

When I’m about to create the journal it doesn’t seems to recognize the path. It just says “the requested URL was not recognized”.
I made the installation right in the root of the domain, so I presume the path should be like where xxx is how I want to name the directory of the journal.
Is that right?

Thanks a lot.

Hi @Adan_Arsuaga,

What server environment are you using? Typically, your installation is located in the Apache web folder (e.g. /var/www/html/ for apache web root - but it may vary based on the hosting environment you are using. You may want to check with your web host to see what they suggest and what your configuration is. You’ll also want to review the README file for installation instructions/configuration:


Thank you very much for your quick answer. Apparently it is indeed installed in the Apache web folder, being:
/var/www/vhosts/ the main path
and: /var/www/vhosts/ where the OJS is installed

The parameters specified in the instructions are correct.

Have you run the installation script yet? After installing the files and setting up the file, you should point your browser to the base_url, which is likely There you can install the software.

If you have got that far, and can access the Admin > Hosted Journals list, click Create a Journal and then click Save. What happens after that? It should take you to the journal settings wizard. And at the top left you should be able to switch to the editorial UI for that journal.

Hi NateWr,

Thanks a lot for your answer. The OJS is installed and it seems to be ok. But when I try to create a new journal, after I click Save there is an error saying “the requested URL was not recognized”.
I think it’s related to the path, and maybe with the permissions of the file.
It has rw- r-- r-- Is that correct? Should I change that?

Thanks again.

I think if you had a permissions problem with the file then you wouldn’t be able to reach the form to create a new journal. I suspect there’s either a problem with the base_url configuration or possibly with a .htaccess file in your root. Can you share those?

Thanks a lot Nate. I think you are right, if the file hadn’t permissions it would have been imposible to install OJS in the first place.
I don’t know how to look the base_url configuration but the .htaccess just says “Deny from all”.
Could this be the problem? How should it be?


The base_url configuration is in in the root directory of OJS. Can you share the full .htaccess file?

Yes, sure. Here is a copy of the htaccess file.

And here I paste the base_url config:
; The canonical URL to the OJS installation (excluding the trailing slash)
base_url = “

; Session cookie name
session_cookie_name = OJSSID

; Session cookie path; if not specified, defaults to the detected base path
; session_cookie_path = /

; Number of days to save login cookie for if user selects to remember
; (set to 0 to force expiration at end of current session)
session_lifetime = 30

; Enable support for running scheduled tasks
; Set this to On if you have set up the scheduled tasks script to
; execute periodically
scheduled_tasks = Off

; Site time zone
; Please refer to lib/pkp/registry/timeZones.xml for a full list of supported
; time zones.
; I.e.:
; time_zone=“Amsterdam”
time_zone = “UTC”

; Short and long date formats
date_format_trunc = “%m-%d”
date_format_short = “%Y-%m-%d”
date_format_long = “%B %e, %Y”
datetime_format_short = “%Y-%m-%d %I:%M %p”
datetime_format_long = “%B %e, %Y - %I:%M %p”
time_format = “%I:%M %p”

; Use URL parameters instead of CGI PATH_INFO. This is useful for broken server
; setups that don’t support the PATH_INFO environment variable.
; WARNING: This option is DEPRECATED and will be removed in the future.
disable_path_info = On

; Use fopen(…) for URL-based reads. Modern versions of dspace
; will not accept requests using fopen, as it does not provide a
; User Agent, so this option is disabled by default. If this feature
; is disabled by PHP’s configuration, this setting will be ignored.
allow_url_fopen = Off

; Base URL override settings: Entries like the following examples can
; be used to override the base URLs used by OJS. If you want to use a
; proxy to rewrite URLs to OJS, configure your proxy’s URL here.
; Syntax: base_url[journal_path] =
; To override URLs that aren’t part of a particular journal, use a
; journal_path of “index”.
; Examples:
; base_url[index] =
; base_url[myJournal] =
; base_url[myOtherJournal] =

; Generate RESTful URLs using mod_rewrite. This requires the
; rewrite directive to be enabled in your .htaccess or httpd.conf.
; See FAQ for more details.
restful_urls = Off

; Allow the X_FORWARDED_FOR header to override the REMOTE_ADDR as the source IP
; Set this to “On” if you are behind a reverse proxy and you control the X_FORWARDED_FOR
; Warning: This defaults to “On” if unset for backwards compatibility.
trust_x_forwarded_for = Off

; Allow javascript files to be served through a content delivery network (set to off to use local files)
enable_cdn = On

; Set the maximum number of citation checking processes that may run in parallel.
; Too high a value can increase server load and lead to too many parallel outgoing
; requests to citation checking web services. Too low a value can lead to significantly
; slower citation checking performance. A reasonable value is probably between 3
; and 10. The more your connection bandwidth allows the better.
citation_checking_max_processes = 3

; Display a message on the site admin and journal manager user home pages if there is an upgrade available
show_upgrade_warning = On

; Set the following parameter to off if you want to work with the uncompiled (non-minified) JavaScript
; source for debugging or if you are working off a development branch without compiled JavaScript.
enable_minified = On

; Provide a unique site ID and OAI base URL to PKP for statistics and security
; alert purposes only.
enable_beacon = On

; Set this to “On” if you would like to only have a single, site-wide Privacy
; Statement, rather than a separate Privacy Statement for each journal. Setting
; this to “Off” will allow you to enter a site-wide Privacy Statement as well
; as separate Privacy Statements for each journal.
sitewide_privacy_statement = Off

i got the same problem, i think it’s because NginX

Hmm, that .htaccess file looks like a problem to me. That will deny all requests to that directory. I’m not sure why you’d be able to login to the site and go to the hosted journals area, though.

Thanks a lot Nate. Doesn’t seem to be the problem. I’ve just leave the htaccess in blank and still have the same issue.

Hi robotebudi. Thanks for your answer but I have no idea what NginX is, do you think is there anything I could do to solve the issue?