Can someone help me upgrade to OJS 3.1.2.3 from OJS 3.1.2.1?

Hello everyone, I have tried to upgrade from OJS 3.1.2.1 to OJS 3.1.2.3 but to no avail. I am being told that,

" You are trying to downgrade the product “openAIRE” from version [2.0.1.5] to version [1.2.0.0]. Downgrades are not supported."

Can someone please help urgently?

Thanks.
Royallite

Hi @royallite,

I suspect you had installed the third-party OpenAIRE plugin maintained here: https://github.com/ojsde/openAIRE

The quickest way to work around this is to remove the plugins/generic/openaire directory from your installation before running the upgrade script. This should permit you to run the upgrade. Then, if you do need this plugin, install it afterwards using the Plugin Gallery.

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like