Blank page in installed plugin tab

In OMP 3.1.1.3 version I get blank page from installed plugin tab.
Here my log:

|2020-02-18 11:00:12|Error|XX.XX.XXX.XXX|500|GET /index.php/folder/$$$call$$$/grid/settings/plugins/settings-plugin-grid/fetch-grid?_=1582019939672 HTTP/1.0|WEBSITE_URL/index.php/folder/management/settings/website|Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.106 Safari/537.36|598|Accesso SSL/TLS Apache|
|—|---|—|---|—|---|—|---|—|
|2020-02-18 11:00:12|Warning|XX.XX.XXX.XXX||AH01071: Got error ‘PHP message: PHP Warning: Declaration of HtmlMonographFilePlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/htmlMonographFile/HtmlMonographFilePlugin.inc.php on line 0PHP message: PHP Warning: Declaration of AddThisPlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/addThis/AddThisPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0’, referer: WEBSITE_URL/index.php/folder/management/settings/website||||Errore di Apache|
|2020-02-18 11:00:12|Warning|XX.XX.XXX.XXX||AH01071: Got error ‘PHP message: PHP Warning: Declaration of HtmlMonographFilePlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/htmlMonographFile/HtmlMonographFilePlugin.inc.php on line 0PHP message: PHP Warning: Declaration of AddThisPlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/addThis/AddThisPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of CategoryGridHandler::doSpecificFetchGridActions($args, $request, &$templateMgr) should be compatible with GridHandler::doSpecificFetchGridActions($args, $request, $templateMgr) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/classes/controllers/grid/CategoryGridHandler.inc.php on line 0PHP message: PHP Warning: Declaration of UploadPluginForm::fetch($request) should be compatible with Form::fetch($request, $template = NULL, $display = false) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/controllers/grid/plugins/form/UploadPluginForm.inc.php on line 22PHP message: PHP Warning: Declaration of UploadPluginForm::execute($request) should be compatible with Form::execute() in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/controllers/grid/plugins/form/UploadPluginForm.inc.php on line 22PHP message: PHP Warning: Declaration of PluginGridHandler::initialize($request) should be compatible with CategoryGridHandler::initialize($request, $args = NULL) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/classes/controllers/grid/plugins/PluginGridHandler.inc.php on line 20PHP message: PHP Warning: Declaration of PluginGridHandler::loadCategoryData($request, &$categoryDataElement, $filter) should be compatible with CategoryGridHandler::loadCategoryData($request, &$categoryDataElement, $filter = NULL) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/classes/controllers/grid/plugins/PluginGridHandler.inc.php on line 20PHP message: PHP Warning: Declaration of SettingsPluginGridHandler::loadCategoryData($request, $categoryDataElement, $filter) should be compatible with PluginGridHandler::loadCategoryData($request, &$categoryDataElement, $filter) in /var/www/vhosts/WEBSITE_FOLDER/controllers/grid/settings/plugins/SettingsPluginGridHandler.inc.php on line 18PHP message: PHP Fatal error: Class PKPNlm30MetadataPlugin contains 2 abstract methods and must therefore be declared abstract or implement the remaining methods (MetadataPlugin::supportsFormat, MetadataPlugin::getSchemaObject) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/plugins/metadata/nlm30/PKPNlm30MetadataPlugin.inc.php on line 0’, referer: WEBSITE_URL/index.php/folder/management/settings/website||||Errore di Apache|
|2020-02-18 11:00:14|Warning|XX.XX.XXX.XXX||AH01071: Got error ‘PHP message: PHP Warning: Declaration of HtmlMonographFilePlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/htmlMonographFile/HtmlMonographFilePlugin.inc.php on line 0PHP message: PHP Warning: Declaration of AddThisPlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/addThis/AddThisPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0PHP message: PHP Warning: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /var/www/vhosts/WEBSITE_FOLDER/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0’, referer: WEBSITE_URL/index.php/folder/management/settings/website||||Errore di Apache|

Thank you,
Enzo

Hi @Enzo,

See DB problem after upgrading from 3.0.2 to 3.1.1.

Regards,
Alec Smecher
Public Knowledge Project Team