Blank Archives page

On, On, /var/log/php_errors.log, 22519

The file /var/log/php_errors.log is empty even after checking permissions, restarting apache, and triggering the blank archives page.

There has to be an error :joy:

Is it possible that you have a .htaccess file in the folder that is overriding those settings?

Maybe just edit the handler I mentioned above and add between rows 119 and 120

ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);

Incredibly, still no errors.
And no .htaccess file :frowning:

I had a look at all these files


and only the last one seems to have configuration points in it - the top three are code.

The files under the 30 folder are maybe a test of some kind. Maybe something you did when you installed the system or upgraded? There is no 30 folder in the default OJS installation.

The one in the API folder is not the correct one, it is the last one that contains the handler which should show the page you are seeing blank. That is also the file you should try adding the error reporting settings I suggested above right after this row But if you already did, then I do not know…

One last thing that comes to mind is to check whether the template is there, so do you have content in this file:

Otherwise, maybe @asmecher or @bozana could look at this.

I just checked /home/www/ and it does contain lines of code… Thanks for the continued help. I appreciate it.

Hi all,

I can hardly say anything when no error message :stuck_out_tongue: I even cannot imagine what is happening that there is nothing in the error log. Maybe something is wrong with the error logging, or it is actually somewhere else, or… Thus, maybe first step would be for you @johnostrowick to find out and be 100% sure where is the right error log file for you OJS installation…

EDIT: And maybe to double check: @johnostrowick, have you changed the navigation menu settings to default again, as mentioned in the first post above:

Under the settings it is linked to archives. So, click journal administration → Settings → Website → Navigation Menus → Navigation menu items → Archives → Edit → link to → Archives → Save.


Hi. That’s precisely the point - there is no error. If you go to the page Archives | Italian Studies in South Africa it is blank. But is not. The error logs (as described at length above) are empty of OJS-related content.

root@www ~ # cat /var/log/php_errors.log | grep -i issa
root@www ~ #


Hi all. I put some output code into the file mentioned above (IssueHandler) and it runs through all successfully.

     * Display the issue archive listings
     * @param $args array
     * @param $request PKPRequest
    function archive($args, $request) {
    echo 'test1';   
     echo 'test2';
            $templateMgr = TemplateManager::getManager($request);
     echo 'test3';           
            $journal = $request->getJournal();
     echo 'test4';
            $rangeInfo = $this->getRangeInfo($request, 'issues');
     echo 'test5';           
            $issueDao = DAORegistry::getDAO('IssueDAO');
     echo 'test6';           
            $publishedIssuesIterator = $issueDao->getPublishedIssues($journal->getId(), $rangeInfo);
     echo 'test7';           
            $templateMgr->assign('issues', $publishedIssuesIterator);
     echo 'test8';           
     echo 'test9';

It gets to test9 without error and without any output except my echos.
Any more ideas? thanks so much in advance.

OK so eventually the following error has come up. I wonder if colleagues could kindly comment on the below error and advise if this may be the cause?

Warning: Cannot modify header information - headers already sent by (output started at /home/www/ in /home/www/ on line 863

Warning: Cannot modify header information - headers already sent by (output started at /home/www/ in /home/www/ on line 864

the error you get now is probably happening because of the echo commands you have there. I would try removing the echo commands now and see if you another error there. That is not an error that would prevent the page to be shown however, or at least I suspect so.

You could try emptying your OJS cache. As I said above, I am running out of ideas…

Yeah, it was because of the echos.
How do I empty the cache?

delete files from cache/t_compile/. On command line you could do: rm cache/t_compile/*.php. But as I said, I have no idea if it helps in this case.



1 Like

I am having the same blank archive page on my installation. i have deleted cache/t_compile content as suggested here without a solution.
i checked my error log file and found this

[Fri Apr 13 09:17:57.247730 2018] [:error] [pid 4659] [client] PHP Fatal error: Call to a member function getPageCount() on array in /home/journal_web/public_html/cache/t_compile/212833ef87fa1fc65e4bb561b9efd6bd26c984b5^%%6B^6B5^6B5271FB%%issueArchive.tpl.php on line 6, referer:

what can i do at this point?
@bozana @ajnyga @MaciejakG


Hi @Gbolly,

See e.g. Error menu archives after upgrade OJS 3.1.1 - #3 by christian_criollo

Alec Smecher
Public Knowledge Project Team

1 Like

Hi @asmecher
it is solved.
many thanks

Gbolahan Idowu

Hi Gbolly

I’m glad you solved your problem

Christian Criollo
University Icesi

Clearing cache helped me as well. Great trick @ajnyga !

Best regards, Primož

Hi there. So it has happened again. A wordpress hacker got in and barfed a whole lot of stuff over the installation and I could not figure out which parts were malware. In particular they replaced the index.php file/s. So I wanted to reinstall. And now I am back to a white screen. I’ve tried 2.4.8 and 3.x series versions, they either exit with an error relating to mysql syntax OR they do a white screen. I’ve tried the above cache clearing already.

Thanks for any advice.