Authors' names missing after upgrade to 3.2.0-3

I’m aware of a similar post in Author´s name missing on web page but this is a little different.

I’ve upgraded from OJS 3.0.2/php 5.6 to 3.2.0-3/php 7.2.

The names of SOME authors in the issue table of contents and article landing pages are no longer showing. See https://www.qualifiedgenealogists.org/ojs/index.php/JGFH/issue/view/3

The missing authors no longer appear in the author table of the database. I tried adding a record to the table for a missing author, but it made no difference.

I also tried unpublish and republish for one of the articles, but there appeared to be no option to add an author.

There is nothing obvious in the error log relating to authors. There are some other issues (e.g. with loading the QuickSubmit plugin) but I’ll post separately about those if I can’t resolve them.

Does anyone have any suggestions?

Hi @Douand22,

Could you (privately) send me a database dump of your OJS 3.0.2 (pre-upgrade) database? I’d like to test the upgrade process locally.

Regards,
Alec Smecher
Public Knowledge Project Team

Weird! The upgrade did seem to run smoothly and no errors were reported. Something happened with images of the volume covers and the mast head and the database lost the filenames. I just added those back in. Some display issues were

My concern is how to correct the problem. I’m reluctant to restore and rerun, and would much prefer to manually add the authors, but how? Unpublishing the articles didn’t appear to have an option to add an author. Adding an entry to the author table didn’t work either, though maybe other tables need to be updated.

Do you have any ideas? Thanks for your help with this.

Andy

Sorry the above message was meant as an email to @asmecher. It was past my bed-time.

Alec kindly reran the upgrade on his server but found no issues with the conversion. Although the cause of the issue hasn’t been identified, I’ve think I have a working solution by adding the missing authors manually to the authors and author_settings tables in the database. This probably isn’t ‘best practice’ but seems to have done the trick.

I hope this is of use to anyone else who has a similar issue.

Hi all,

If anyone is able to shed some light on the issue of missing authors, please feel free to follow up! I wasn’t able to reproduce it locally, but would still like to know more about how it happened.

@Douand22, re-adding the data manually should get you through for small volumes of content.

Regards,
Alec Smecher
Public Knowledge Project Team