##api.submissions.unknownError## Modal

We received this error modal:

There was no action on our files (no code editing)
We download and upload te folder Journal to our online server. Since then we receive this error modal
when we login

  • Application Version, OJS 3.1.2 but i am not sure


Hi @dim,

Please verify the version of OJS you’re using (there’s a FAQ entry in this forum that can help), and check your PHP error log for details (there’s also a FAQ entry for this).

Alec Smecher
Public Knowledge Project Team

We receive this error:

The console says:

Fatal Error: Uncaught exception 'RuntimeException; with message 'Unexpected data in output buffer. Maybe you have characters before an opening <?php tag?; in var/www.vhosts/[designforsocialchange.org/http-docs/journal/lib/pkp/lib/vendor/slim/slim/Slim/App.php:622](http://designforsocialchange.org/http-docs/journal/lib/pkp/lib/vendor/slim/slim/Slim/App.php:622)

Hi @dim,

The most likely cause of this is that your server is configured to display PHP errors. This causes problems for responses from the API.

Make sure that your server is configured to log PHP errors to a special error log. Usually this is specified in a php.ini file, but there are many different ways to do this depending on your setup.

Ok but what causes the loss of our submissions?
Our previous submissions were not there and the new one are not displaying in dashboard. But the users got e-mails that their submissions are submitted

Thank you

Can I have detailed help? I really don’t know how to do that :frowning:

You’ll need to go to the technical support wherever your journal is hosted. This will be who runs the server and they will know how to make this happen.

Ok but what causes the loss of our submissions?

The submissions are probably there. It’s most likely the request which retrieves them for display that is failing, so they can’t be displayed correctly.

Hello All,

I’m using OJS .

I have already disable below setting based on the available results in the forum :

disable_path_info=off also restful_urls = Off

When I login to my ojs profile, It works fine for me. But my Chinese client is getting this error


Any advice is much appreciated.

Thanks Advanced!!!


Hi @venkat,

If you haven’t turned off session_check_ip in your config.inc.php configuration file, I’d suggest doing so. The Chinese user is probably changing IP addresses due to the firewall.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

Thanks for your quick response, its really appreciable.

Let me check with my Chinese user.