“api.submission.unknownError" after updrage from OJS 3.1.0 to 3.1.1 - PROBLEM SOLVED

Hi there,

I have upgrade my OJS system from 3.1.0-1 to 3.1.1 version.53%20PM46

When I enter the OJS system as admin I immediately receive an image “api.submission.unknownError” I am attaching a photo.

Additionally, when I try to navigate thru the website, I am unable to
see “Masthead” in Journal setting, “Appearance” in website setting,
“Submission” and “Review” in Workflow setting, and the list of my
“Users”: it says “loading” but it does not load the list of the users.

I am attaching the error log file that I retrived when I click on the
above-mentioned field and when I click on “ok” regarding the api. error.


When you upgraded your OJS, did you change your character set configuration settings in config.inc.php?

Alec Smecher
Public Knowledge Project Team

Hi Alec,
thank you for your so fast reply.
I am not sure.
How am I supposed to change it? What change shuold I perform? …like from off to on?

Thank you once again.

This is what I have in config.inc.php

; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = utf-8

; Database storage character set
; Must be set to “Off” if not supported by the database server
database_charset = utf-8

; Enable character normalization to utf-8 (recommended)
; If disabled, strings will be passed through in their native encoding
; Note that client_charset and database collation must be set
; to “utf-8” for this to work, as characters are stored in utf-8
charset_normalization = On


Hi Alec,
sorry if I am sending you my third email, but I think this is important for other users.
I solved the problem in this way:

  1. I replaced the term “utf-8” with “utf8” (without dash)
  2. After correcting this error, I had to delete all the files in the folder “cache”, saved, and rebooted the system.

Now, I no longer see the ERROR API, as well as I can navigate thru the entire system and I can see everything.
THank you once again!
I do not know how to share this info on the forum.




Thanks for following up – yes, the inconsistency between utf-8 and utf8 has tripped up a few users; unfortunately it’s what the various libraries and tools built into OJS expect, even if it’s not consistent.

Alec Smecher
Public Knowledge Project Team