After upgrading to any 3.2.X does not show some forms from the administrative area

I’m updating a magazine that was at version 2.4.8-2, the target would be to reach version 3.2.1-1, I first updated to version 3.0.2-0, apparently everything is OK. When I try to upgrade to 3.2.X (tried 3.2.0, 3.2.1-1 and 3.2.1-3) in all these versions the same thing happens, the upgrade is completed successfully, apparently everything is fine in the public area , but in the administrative area it does not show some forms.

For example:

Settings > Magazine > Editorial Team

Settings > Website > Appearance > Configure

These are some examples, but other forms are exhibiting the same behavior. Others are working correctly.

In the browser console I get the following error:

build.js?v= TypeError: Cannot read property ‘length’ of null
at o.Ye (build.js?v=
at o.e._render (build.js?v=
at o.i (build.js?v=
at ri.get (build.js?v=
at new ri (build.js?v=
at In (build.js?v=
at o.wi.$mount (build.js?v=
at o.wi.$mount (build.js?v=
at init (build.js?v=
at h (build.js?v=

If anyone can give me a suggestion. I tried to put it in debug mode but I didn’t find any error that could justify this behavior, basically messages like “notice”.

Hi @elims,

This is almost certainly caused by the Administration settings → Languages not being migrated correctly. Fortunately it is easy to solve.

Go to Administration, then Site Settings, click “languages” and make sure that at least one language in your installation has all of the checkboxes checked on, for forums, ui, submissions, etc. That should fix things.


Actually, sorry, I didn’t realize you were upgrading to 3.2. In that case, go to Administration → Site Settings → Languages, and make sure at least one of those is enabled, and then go to Website Settings → Setup → Languages, and check off the boxes:

Screenshot at 2021-07-12 14-19-01