3.2.1.1 upgrade - session error

[09-Sep-2020 04:03:45 America/Chicago] PHP Warning: Version warning: Imagick was compiled against Image Magick version 1654 but version 1650 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
I have upgraded from 3.1.2 to 3.2.1.1. I got sucessfull message but the following error message comes when I visit the site. Please help me

[09-Sep-2020 04:03:45 America/Chicago] PHP Warning: ini_set(): A session is active. You cannot change the session module’s ini settings at this time in /home1/jott/public_html/test.threatenedtaxa.org/lib/pkp/classes/session/SessionManager.inc.php on line 69
[09-Sep-2020 04:03:45 America/Chicago] PHP Warning: Cannot modify header information - headers already sent by (output started at /home1/jott/public_html/test.threatenedtaxa.org/lib/pkp/classes/session/SessionManager.inc.php:69) in /home1/jott/public_html/test.threatenedtaxa.org/lib/pkp/classes/session/SessionManager.inc.php on line 224
[09-Sep-2020 04:03:45 America/Chicago] PHP Warning: Cannot modify header information - headers already sent by (output started at /home1/jott/public_html/test.threatenedtaxa.org/lib/pkp/classes/session/SessionManager.inc.php:69) in /home1/jott/public_html/test.threatenedtaxa.org/lib/pkp/classes/session/SessionManager.inc.php on line 232
[09-Sep-2020 04:03:45 America/Chicago] PHP Warning: Cannot modify header information - headers already sent by (output started at /home1/jott/public_html/test.threatenedtaxa.org/lib/pkp/classes/session/SessionManager.inc.php:69) in /home1/jott/public_html/test.threatenedtaxa.org/lib/pkp/classes/core/PKPRequest.inc.php on line 97

Hello @latha_ojs

It’s not an exact solution, but you may wish to see the post here: Error Upgrading from OJS 3.1.1.4 to 3.1.2 - which reports some issues very similar to your own.

-Roger

Thank you. Will try.

Hello Iatha, I have exactly the same issue here with our 3.2.1.1 websites. The problem occurs after a link is clicked from OPS into a OJS, and when a multilingual journal switches language. It disappears when removing the www. from the url. :face_with_raised_eyebrow:

The message is displayed at the top of the screen. I am uneasy about this because it lays bare for everyone to see the file structure on my server, which is normally hidden from view. Is this a good idea?

I have searched for remedies online, didn’t found one. I do understand that:

The message means that you have started a session with session_start() in which further down in the code you are using ini_set () to manipulate the session module. If you are manipulating the session module, it should be done before a session is started and active.

Now, if you uncomment line 69 in the file SessionManager.inc.php (adding two slashes // in front of it) the problem disappears and doesn’t return. The website functions like it should with no visible errors. :no_mouth:

// ini_set(‘session.cookie_domain’, $this->userSession->getDomain());

I am sure this isn’t a final solution but it works for now.

Hi @Franklinx,

You probably have a collision in cookie names. You can make sure each application uses a different cookie name by setting one for each application in config.inc.php.

You’re right that errors/warnings should not be sent to end users. You can control this in your PHP configuration.

Regards,
Alec Smecher
Public Knowledge Project Team